Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Wake ON LAN

  • Hallo alle.

    Für die älteren Dreamboxen mit Mipsel gibt es ja einiges, um Wake On LAN durchzuführen (etherwake, LanControl2 plugin, etc.).

    Für die 7080 und 820 fand ich nach Googeln heute sogar ein *.deb Plugin, das wegen ARM aber vermutlich wohl nicht mit dr 900 und 920 zu gebrauchen ist.


    Ich will nur hin und wieder mal mein NAS aus der Ferne mittels Fernbedienung einschalten. Also nicht automatsich bei jedem Start meiner DM920UHD.

    Auf meinen beiden alten DM8000 habe ich LanControl2 fürs Aufwecken des NAS benutzt und und zum Ausschalten ein shutdown.sh Script.

    Das hat mir netterweise Fred Bogus Trumper damals gegeben und das sollte auch heute wohl noch auf der DM920UHD funktionieren.




    Jetzt las ich jüngst hier im Forum irgendwo (no idea, where), dass SysCC der neue Ersatz für DreamCC ist und im Großen und Ganzen quasi nichts anderes als ein (User) Script Starter sein soll.


    Lange Rede kurzer Sinn:

    Habe nach einem Start Script für mein NAS gesucht und eines hier gefunden, das ich hoffentlich benutzen könnte.


    Fragen:

    Wenn ich das gefundene Script anpasse, also im Code MAC und IP Adresse meines NAS einfüge und den Code mit Notepad++ als wol_autostart.sh speichere, dieses Script dann nach /user/script kopiere und mit Attribut 755 versehe, ...


    a) ist es so lauffähig ?

    b) kann ich es dann mit SysCC von Hand bei Bedarf starten?

    c) falls ja, wie?


    Hatte meine beiden Scripts (für NAS Start und Shutdown) schon nach /user/sript kopiert und dann sysCC gestartet, aber dort erscheint kein Script und ich wüsste auch nicht, wie ich es hinzufügen kann.

    Grün = START und Rot = STOP ist alles, was ich dort finde.


    (Kann gerade wegen laufender TV Aufnahme meine Box nicht neu starten, falls das nötig gewesen wäre.)

  • Lancontrol2 müsste eigentlich immer noch funktionieren. Da ist ja kein binary drin

  • Hallo Dre :)


    Ja, LanControl2 funktioniert auf meiner alten 8000er immer noch (soeben ausprobiert).

    Das ist aber nicht auf dem Feed für meine 920er. Weder bei Merlin noch bei DP. Vermutlich gibt´s das noch bei www,Dreamboxupdate in der Paketliste als ipk.


    Umbauen von ipk zu deb, sofern so etwas möglich wäre, kann ich nicht.


    Falls man ein ipk aber auch auf der 920 installieren könnte (denke mal, NEIN),, gäb´s das nächste Problem.

    LanControl2 kann das NAS nur einschalten nicht aber wieder ausschalten. Wäre nicht sooo schlimm, da der nächste Timer Event vom NAS selbst das tun würde. Da läuft die Kiste eben ein paar Stunden länger.


    Eleganter wäre es mit zwei Scripts zum Ein- und Ausschalten. Zum Ausschalten habe ich früher mein shutdown.sh benutzt und zwar über den DReamExplorer.

    Der hat den Vorteil, dass er im Addon Manager auf dem Feed liegt. Habe ihn gerade installiert, ausprobiert und Pech:


    Beide Scripts funktionieren nicht.

    Auch das shutdowmn.sh nicht mehr, das früher funktioniert hat.


    Ich bekomme immer folgende Fehlermeldung (Bad Interpreter):


    Fehlermeldung.PNG



    Die Scripte sehen so aus:


    Für den NAS Start


    Für´s Ausschalten



    (Die Scripte haben Rechte 755 und liegen in /user/script)

    Hat jemand eine Ahnung, ob und wie man die Scripte so anpassen kann, dass sie zu meinem Synology DS713+ mit stets aktueller Firmware (Autoupdate) durchdringen?


    Ansonsten muss ich´s wohl aufgeben.


    Gerade getestet.

    PS: Wenn ich im Startscript die Ausrufezeichen um target_mac und target_ip entferne, hängt das Script bei Ausführung bei line 11 mit wol - no such command

    Hat sich da der Befehl (wol) für das magic packet geändert?


    (Die 920 musste ich mit e2 im Telnet neu starten, daher kein Screenshot von der Fehlermeldung).

    Gruß, ararat :)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von ararat () aus folgendem Grund: Ergänzung

  • "enigma2-plugin-extensions-lancontrol2" ist jetzt (ungetestet) auf dem 920-Feed verfügbar.

  • Das Plugin gab es nie bei deeamboxupdate. Das Herunterfahren war mal vorgesehen. Da gab es dann aber so viele Abhängigkeiten zum Server-OS

  • Hallo weazle und Dre  :):)


    Habe LanControl2 eben (bereits vor der Meldung hier im Thread) im Feed entdeckt.

    Danke! :)

    Muss vermutlich aber erst mal ein anderes Problem lösen.


    Habe eben eine Wiedergabe von Festplatte gestartet. Der Film begann (Ton war zu hören), aber die Aufnahmeliste hing mit Spinner für mehrere Sekunden, bis endlich die Abfrage kam, ob ich zum zuletzt geschauten Zeitpunkt springen wolle.


    Habe dann zuerst mal das Dateisystem der Festplatte überprüft (Menü/Einstellungen/Geräte/Speichergeräte/ Test mit Grün = 0 Fehler).

    Anschließend habe ich dBackup mit Menu/Gelb (Überprüfen)/root bemüht.

    Vermute mal, dass folgende Meldung nichts Gutes verheißt. Hoffentlich reicht es neu zu flashen?


    Bildschirmfoto 2018-03-01 um 16.06.34.png


    Das NAS Mini-Problem muss ich wohl erst mal in der Priorität nach hinten schieben.


    PS.:

    Oder ist die obige Meldung normal, wenn man zu dBackup (vom Merlin Feed) den Zusatz

    e2fsprogs nicht installiert hat, welcher zum Markieren und Deaktivieren von Bad Blocks dient und früher bei dFlash immer automatisch mit dabei war?

    In dBackup steht, dass das Programm auf meiner 920 fehlt.

    Keine Ahnung, wo ich e2fsprogs für die 920 herbekommen soll. Auf dem Feed (Merlin und DP) finde ich es nicht und von Sourceforge.net weiß ich nicht, ob ich´s einfach so für die Dreambox nehmen kann.

    (Dort gibt es Version 1.43.9.tar.gz bei der ich sowieso nicht wüsste, wie sie zu installieren ginge.)

  • zum dbackup kann dir hier keiner vom team helfen , das nutz keiner ...

    Damit eventuelle mal im ozzoon-board bei gutemine nachfragen in dem supportthread da :)

  • Hallo ketschuss :)


    Ja, wegen dBackup und e2fsprogs muss ich wohl bei oozoon anfragen. (Sofern überhaupt ein Problem besteht und die obige Fehlermeldung ohne e2fsprogs nicht normal ist.)


    Mein heutiges Problem, dass beim Wiedergabestart einer Aufzeichnung die Aufzeichnungsliste mit Spinner hängt, bevor die Abfrage kommt, ob man zum zuletzt geschauten Zeitpunkt springen will, habe ich beseitigt. :)


    Schuld war der heute Morgen vom Feed installierte Dreamexplorer. Habe den deinstalliert und die Filme springen wieder sofort an. :)

    Vermutlich hat der DreamExplorer das gleiche Problem wie der MultiGraphEPG es bis vor kurzem noch hatte. (Hat Dr.Best inzwischen behoben)

    Da fragt der Code vermmutlich inaktive Netzwerkressourcen ab. Mein Nas ist tagsüber ausgeschaltet und startet erst heute ab 22 Uhr. Das wird wohl der Grund gewesen sein.


    Werde mir dann auch wohl besser LanControl2 verkneifen. Da muss ich sonst womöglich 24/7 mein NAS laufen lassen, wenn nichts haken soll.

    Geht man eben die paar Schrtitte zu Fuß zum NAS, um es einzuschalten.

    Kann ja auch meinen Laptop anwerfen und via Fritz!Box Netzwerkeinstellungen das NAS per Mausklick starten.


    A propos Laptop - mal eine Frage:

    Kann man im Webbrowser der Dreambox nur Googeln und sonst keine IP Adresse von Hand eintragen:?:

    Wenn doch, könnte man mit der Dreambox ja die Fritz!Box (oder Router anderer Hersteller) Oberfläche aufrufen und dann darüber den WOL Button für das NAS drücken (ohne Laptop / ohne zusätzliche Dreambox-Plugins).

    Auch das Herunterfahren könnte man ja per Weboberfläche des NAS erledigen, sofern man dessen IP im Dreambox Webbrowser eingeben könnte.

  • Super dreamer-flt :)


    Dann ist das NAS Problem doch mit zwei Bookmarks fürs Ein- und Ausschalten gelöst. :klatsch:

    Passwörter für´s Login habe ich zum Glück im Kopf. Nur die Eingabe mit FB ohne Tastatur wird vermutlich etwas umständlich. ;)

  • Nein, DreamExplorer lädt keine Picons. Somit hat der sicher nicht das gleiche Problem


    Da wurde auch nichts geändert ausser dem Crashfix und Entfernung von unnötigen Code

  • Hallo Dre  :)


    Danke für die Info.

    Was auch immer der DreamExplorer macht - seit er wieder herunter ist von der Box, geht auch die Festplatte wieder normal.

    Natürlich Glaskugelraten ohne Log. Will den jetzt aber nicht noch mal extra neu wieder installieren.


    PS.:

    An Picons lag das verzögerte Reagieren beim GraphMultiEPG bei mir damals nicht. Die hatte ich dort abgeschaltet. Da war etwas am Code zu ändern gewesen.

  • Es lag daran. Kannst mir glauben. Ich hab ja den commit gesehen. Damit die Picons angezeigt werden, braucht es auch Code und da war was unschön/unsauber gelöst.


    Installieren und loggen wäre das einzige, was uns helfen könnte. Aber wäre sicher was anderes als beim GraphMultiEPG

  • Die Welt wäre so viel einfacher mit einem Zeilenende

  • Hallo Dre und Fred Bogus Trumper  :)


    Es lag daran. Kannst mir glauben. Ich hab ja den commit gesehen. Damit die Picons angezeigt werden, braucht es auch Code und da war was unschön/unsauber gelöst.


    Ich hatte aber im Menü vom MultiGraphEPG eingestellt: Picons NEIN

    Wenn´das Plugin dann dennoch danach gesucht hat, kann´s daran gelegen haben. ;)



    dos2unix /usr/script/autostart_WOL.sh


    würde wahrscheinlich auch den Fehler aus Post #3 beheben


    Leider nein.

    Das alte Shutdown.sh Script, das ich benutz habe, war schon seit Jahren Unix konform und funktionierte immer. Es funktioniert aber selbst auf meiner alten 8000er, wo es nie verändert wurde nicht mehr. Zudem hatte ich es, ohne es zu editieren, einfach so von der 8000 kopiert, da das auf dem NAS Speziell zu diesem Zweck erstellte Passwort und die IP Adresse des NAS im Heimnetz unveräöndert waren.


    Habe eben auf der 8000 das immer funktionierende Script extra noch einmal ausprobiert. Es geht nicht mehr.

    Da hat sich also vermutlich eher beim NAS etwas geändert. Das versteht vermutlich irgend einen Befehl nicht mehr. Immerhin wurde die Firmware regelmäßig upgedated und evtl. bei Synology da etwas verändert.


    Das neu erstellte Startscript, also den Code aus dem Netz, hatte ich mit Copy & Paste in Notepad++ eingefügt (nicht in Windows Notepad). Ich habe nur die MAC Adresse und die IP Adresse und sonst nichts editiert. Abgespeichert habe ichdas Script mit "Datei Speichern unter" als "Unix Script File" mit der Bezeichnung wol_autostart.bash und das dann umbenannt in wol_autostart.sh.

    Da dürfte eigentlich kein CR drin sein, sondern nur ein LF.


    Es liegt also nicht am Zeilenende. Da hakt was anderes.


    Habe gestern aber schon mit der 920 mein NAS per Webbrowser starten können.

    Fritz!Box Oberfläche als Bookmark und darin dann Netzwerk (Geräteliste)/Synolgy DS713+/bearbeiten und dort den Knopf "Gerät starten". Ausloggen aus Fritz.


    Jetzt kann ich mir noch ein Bookmark zu meiner NAS Oberfläche in den Browser legen (vermute mal, dass https da nicht geht und nehme http://NasAdresse). Einloggen und NAS Herunterfahren. Ausloggen nicht nötig.


    Umständlich, aber möglich.