Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Installation von diversen Paketen

  • Hallo,


    ich habe versucht laut faq mediaportal zu installieren:


    https://board.dreambox.tools/i…d_merlin_wie_installieren



    Code
    1. debinstall /home/enigma2-plugin-extensions-mediaportal_all.deb
    2. dpkg: error processing archive /home/enigma2-plugin-extensions-mediaportal_all.deb/*.deb (--install):
    3. cannot access archive: No such file or directory
    4. Errors were encountered while processing:
    5. /home/enigma2-plugin-extensions-mediaportal_all.deb/*.deb
    6. Reading package lists... Done
    7. Building dependency tree
    8. Reading state information... Done
    9. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Kann mir hier jemand auf die Sprünge helfen? Danke!

  • OK, hat jetzt geklappt mit


    dpkg -i enigma2-plugin-extensions-mediaportal_all.deb


    und die Abhängigkeiten habe ich dann mit


    apt-get update && apt-get -f install


    installiert.


    Warum meckert das System immer


    WARNING: The following packages cannot be authenticated!


    ist das normal?

  • ja .. Meldung ist normal


    Und bei debinstall muß das deb-file in /tmp befinden ( steht auch so in der faq die du verlinkt hast ) ... was ja bei dir nicht der fall war ;) siehe deine gepostete ausgabe

  • ahh, ich dachte temp ist nur ein Beispiel, mir war nicht klar, dass es ein muss ist


    Auch wenn ich etwas vom topic abschweife, was mache ich dann hier falsch:


    Code
    1. debinstall /tmp/enigma2-plugin-extensions-yampmusicplayer_3.2.2_r1_2017_12_18_all.deb
    2. shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    3. dpkg: error processing archive /tmp/enigma2-plugin-extensions-yampmusicplayer_3.2.2_r1_2017_12_18_all.deb/*.deb (--install):
    4. cannot access archive: Not a directory
    5. Errors were encountered while processing:
    6. /tmp/enigma2-plugin-extensions-yampmusicplayer_3.2.2_r1_2017_12_18_all.deb/*.deb
    7. Reading package lists... Done
    8. Building dependency tree
    9. Reading state information... Done
    10. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    beim manuellen installieren sagt er es fehlt beautifulsoup


    Läuft yamp unter Merlin überhaupt?

  • bei debinstall auch kein file angeben ... einfach nur debinstall absetzen auf der konsole :)

    Das sucht dann selber nach installierbaren files in /tmp und installiert diese dann


    Nachtrag > siehe dazu auch hier https://board.dreambox.tools/i…/28-merlin-images-aliase/

  • Ahh, OK, danke für den Link.


    Aber es bleibt das Problem mit beautifulsoup

    Weiß da jemand eine Lösung?

  • Ich habe das Paket python-beautifulsoup4_4.3.2-r0.1_armhf.deb auf dem nn2 feed gefunden und installiert, dann ging auch yamp.


    Ich weiß, der MerlinMusicPlayer ist auch toll, aber bei gemischten Boxen/Images im Hause ist es (gerade für die anderen User im Hause) schöner wenn die Plugin auf allen Boxen gleich sind. Vielleicht ist das Merlin team ja doch mal so nett und fügt python-beautifulsoup dem feed hinzu, das wäre super!


    Danke !

  • Bitte nicht für jeden Fehler einen Thread aufmachen, wenn du Dinge installierst, die nicht bei uns auf dem Feed liegen. Dann musst du dich schon selbst um die Abhängigkeiten kümmern.