Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Streaming Server

  • Ich konnte damit meine Dream nicht verbinden. hast du DM900 ? Läuft es ausserlalb deines WLANs ??

    ? dabei mal am https- und hijackschutz gedacht den die dreambox jetzt standardmässig auf on hat.

  • Das muss zuerst funktionieren , dann würde man weiter überlegen was man damit macht.

    Habe gehört es gibt Menschen die Alexa oder dieses Google Zeug im Netz hat das ständig mit 11 Mikrofonen ALLES an die Große Welt weiter gibt. Was soll dann schon meine Dream verraten ?! Wäre zwar unangenehm aber das ist ganz anderes Thema.

  • Ich konnte damit meine Dream nicht verbinden. hast du DM900 ? Läuft es ausserlalb deines WLANs ??

    Ich habe eine DM7080 und schaue darüber ausserhalb des WLANs über eine VPN-Verbindung - Fritzbox/iPhone.


    App - vuplusTV

  • Hallo,

    ich hatte schon vor längerer Zeit in diversen Foren geschrieben, dass bei mir der rtsp Stream bei meiner Dream nicht von aussen funktoniert. Nach etlichen Versuchen und probieren hab ich glaube den Fehler gefunden. Meine Kabel Fritzbox 6490 lässt (wahrscheinlich bedingt durch das Live TV diesen Port nicht durch). Hab sämtliche Einstellungen mal probiert und komischerweise hat es damals mit meiner alten Fritzbox funktioinert.

    Daher nur mal zum Test, kann ich irgendwo in der Dreambox Config den rtsp Stream Port 554 in einen anderen ändern? Kann mich erinnern, dass das früher mal im Menü ging.


    Gruß

    neo


    PS: Der HLS Stream läuft ohne Problme von ausserhalb mit Portfreigabe.

  • Ich nutz das Ding nicht, aber kann das nicht im WebIf festgelegt werden?

  • In /etc/enigma2/settings wird der Port noch ausgewertet:


    config.streamserver.rtsp.path=stream

    config.streamserver.rtsp.enabled=false

    config.streamserver.rtsp.port=554


    ... Ist halt nur neuerdings im OSD von DMM/DP wegrationalisiert worden.


    Code
    1. systemctl stop enigma2
    2. ...  /etc/enigma2/settings editieren (config.streamserver.rtsp.port=554)
    3. systemctl start enigma2


    sollte helfen.

  • Bei mir steht es so drinnen


    config.streamserver.rtsp.path=stream

    config.streamserver.rtsp.enabled=true

    config.streamserver.rtsp.port=554


    Und wenn ich das ändere in


    config.streamserver.rtsp.path=stream

    config.streamserver.rtsp.enabled=false

    config.streamserver.rtsp.port=zB. 456


    dann sind nach einem Neustart wieder die alten Werte drinnen.


    Komisch!

  • Wer lesen kann ist klar im Vorteil....bleibt jetzt drinnen, aber leider bringt die Änderung nichts. Der Streaming Server ist weiterhin nur mit dem alten Port 554 erreichbar. Muss also noch woanders drinnen stehen.

  • Ach Mist. Hab gehofft, dass ich den Bug in der Fritzbox umgehen kann und dann wenigstens den Port in der Dream ändern kann. Glaub nicht, dass DM dann was wegen eines einzeln ändern wird. Trotzdem danke für die Hilfe!

  • Sorry, aber hast du überhaupt mal im WebIf nachgeschaut???? Wenn ich unter Extras auf Einstellungen gehe, dann kann ich dort den rtsp-Port einstellen.

  • So, die Testratte hat das mal durchgecheckt


    Händisches ändern des Ports bei gestoppten enigma2 in /etc/enigma2/settings


    Code
    1. config.streamserver.rtsp.port=123


    übersteht einen (GUI) Neustart nicht und wird mit 554 überschrieben.


    Ändern des RTSP Ports im Webif ist funktionslos. Es wird immer 554 genommen.

  • Händisches ändern des Ports bei gestoppten enigma2 in /etc/enigma2/settings


    Code
    1. config.streamserver.rtsp.port=123


    übersteht einen (GUI) Neustart nicht und wird mit 554 überschrieben.

    Das übersteht es jetzt bei mir. Wenn ich 554 in 123 überschreibe bei gestoppten enigma 2 und dann gestartetem enigma 2 bleibt bei mir der Port bei 123. Nur der Streaming Server ist mit der Adresse rtsp://IPderBox:123/stream nicht erreichbar, sondern nur mit rtsp://IpderBox:554/stream


    Auch nach kompletten Neustart keine Änderung.