Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Timeout Einstellung Netzwerkbrowser

  • Frage, habe mein FritzNas per Netzwerkbrowser eingebunden, alles gut!

    Falls kein Netzwerkkabel angeschlossen ist, dauert das booten der DM920 relativ lange.

    die fstab schaut so aus bezüglich der FritzNAs Einbindung

    Frage, sind die Einstellungen

    x-systemd.device-timeout=15 und x-systemd.idle-timeout=60 für die Verzögerung zuständig, und kann man mit Änderung der Parameter den Bootvorgang beschleunigen, falls mal kein Netzwerkkabel angeschlossen ist.

    Wenn ja, welcher von beiden werten ist für das delay beim booten zuständig

    thx

  • kannst ja mal x-systemd.device-timeout=5 in der fstab versuchen

    https://www.freedesktop.org/so…md/man/systemd.mount.html

    Hi, nach einem reboot, ist der Eintrag x-systemd.device-timeout zweimal vorhanden, einmal mit den geänderten Wert 5 und mit dem Standard Wert 15

    Booten dauert mit abgesteckten Netzwerkabel dann 120 sekunden

  • Was steht denn in den Mountmanager Einstellungen? Der überschreibt die fstab nicht sondern erstellt einen neuen Eintrag ...

    Der ist buggy und das ist seit Beginn von OE2.5 bekannt ...


    beste Vorgehensweise:

    die Datei /etc/enigma2/automounts.xml unbenennen in automounts.xml.off oder ähnliches oder ganz löschen und dann den alten Eintrag mit den den 15 Sekunden aus der fstab löschen und rebooten


    Wenn das funktioniert den Mountmanger zukünftig nicht mehr anfassen und nur noch über die fstab mounten. Der Mountmanager schreibt in die .xml und in die fstab random was ihm gerade einfällt wenn man bestehende mounts ändert und vergisst sogar Einträge aus der fstab zu löschen, wenn man einen mount löscht ...


    Um einen neuen mount zu testen bzw. eine Änderung zu übernehmen kann man anstatt zu rebooten auch das remote-fs-target über die Konsole neu starten:



    systemctl restart remote-fs.target


    Wenn man einen neuen share einbinden will, muss man den mountpoint dann manuell anlegen, falls dieser nicht existiert - das mach sonst der Mountmanager automatisch

  • Fred Bogus Trumper


    automounts.xml unbenannt in automounts.xml.off

    Und


    x-systemd.device-timeout auf 5 gesetzt,

    Die Einstellung Bleibt jetzt auch bestehen, jedoch ist das booten der dm920 Ohne Netzwerkkabel genau so lange , ca. 120 Sekunden


    Das Problem tauchte deshalb auf da die dm920 Temporär in einem Nebenzimmer betrieben wurde, wo kein Netzwerkkabel vorhanden ist und auch nicht benötigt wird

  • Ich habe damit auch schon unendlich viel Zeit verplempert.

    Egal was ich eingestellt hatte, keine Aenderung.

    Ich denke da ist irgendwo grundsaetzlich ein Bug d'rin.

    Inzwischen habe ich es aufgegeben und abgehakt.

  • Doch, das klappt schon. Mein Eintrag in der fstab sieht so aus:

    Code
    1. 192.168.178.51:/volume1/video /media/DS1 nfs x-systemd.automount,x-systemd.idle-timeout=60,noauto,nofail,soft,timeo=2,retrans=1,retry=0 0 0

    Entscheidend ist timeo = 2. Der Mountversuch wird hier nach 2 sec abgebrochen.

  • Zitat

    sodele, wieder online, habe timeo in die fstab integriert, leider ohne Erfolg

    Oder liegt es daran das ein cifs Mount ist

  • Ja, könnte daran liegen. Mit cifs habe ich es nicht getestet. Die Parameter sind dort teilweise andere. Kann denn die Fritzbox kein NFS?

    NFS ist bei Mounts mit der Dreambox auf jeden Fall unproblematischer.

  • Ja, könnte daran liegen. Mit cifs habe ich es nicht getestet. Die Parameter sind dort teilweise andere. Kann denn die Fritzbox kein NFS?

    NFS ist bei Mounts mit der Dreambox auf jeden Fall unproblematischer.

    hi, danke für die Unterstützung, leider kann das FritzNas kein NFS, sondern nur CIFS

  • Bei mir steht in der fstab ein minimalistrischer CIFS Mount zur Fritzbox ...


    Code
    1. //FRITZ.NAS/fritz.nas/nas/videos    /media/nas/Videos_Fritzbox cifs username=ftpuser,password=blabla



    ... und der entsprechendem Dreambox ist es egal ob mit oder ohne Netzwerkkabel - sie bootet in der selben Zeit hoch.

  • Dann schau doch erst mal nach, was in der Shell "mount" an Fehlermeldungen zurückliefert.

    Bei deinem obigen Beispiel des fstab Eintrages also eintippen:


    "mount /media/FRITZNAS"


    Und bei der Gelegenheit gleich mal nachschauen, ob bei deiner Dreambox das Verzeichnis "/media/FRITZNAS" (Groß/Kleinschreibung ist bei Unix nicht egal!) überhaupt existiert. Wenn nicht vorhanden, wird auch nicht gemountet.


    Wahrscheinlich ist "FRITZ.NAS" in deinem Mount falsch


    Der korrekte Pfad wäre


    //192.168.2.1/fritz.box/<name des zu mountenden Gerätes> /media/FRITZNAS cifs username=ftpuser,password=123456

  • So irgendwie komme ich nicht weiter,


    in der fstab habe ich das stehen


    das Verzeichnis "/media/FRITZNAS" auf der Dreambox ist vorhanden,


    nach Neustart ist das Verzeichnis "/media/FRITZNAS" leer, kein mount erfolgt.

    Wenn ich jetzt per telnet den Befehl "mount /media/FRITZNAS" Eingebe erfolgt keine Fehlermeldung und

    die FritzNas ist gemountet


    Hier die Einstellung der fritzbox


    nas1.JPG



    wie gesagt mit der fstab- original, wird das FritzNAs gemountet, jedoch bei fehlendem Netzwerkkabel, dauert der Bootvorgang 120 sekunden

    ich habe jetzt ähnliche problematik im dreambox board gefunden, wollte jetzt aber nicht wegen einem Crosspost, gesteinigt werden.

    Vielleicht gibt es ja noch eine Lösung die mir weiterhilft.
    thx

  • Hast du diesen Parameter mal in der fstab-original versucht ?


    echo_interval=n

    sets the interval at which echo requests are sent to the server on an idling connection. This setting also affects the time required for a connection to an unresponsive server to timeout. Here n is the echo interval in seconds. The reconnection happens at twice the value of the echo_interval set for an unresponsive server. If this option is not given then the default value of 60 seconds is used. The minimum tunable value is 1 second and maximum can go up to 600 seconds.


    Keine Ahnung, ob der hier funktioniert, aber im Netz wird er oft erwähnt.

    Ein Versuch wäre es wert ;)


    Ich bin jetzt auch nicht der mount-Experte, aber in deinem neuen fstab-Eintrag fehlt bestimmt irgendwas mit "auto", damit er eigenständig mounted.

    Alle meine Einträge haben sowas wie .../media/... "tabtaste" auto "tabtaste" auto, ... drin.

  • @all

    Ich meine ich habe den Fehler gefunden

    Aus meiner Sicht lässt sich der Fehler reproduzieren, meiner Meinung nach liegt es am Merlin Image, warum verstehe ich auch nicht!


    Ich habe ein clean installation durchgeführt zuerst mit,

    - mit dem original image von DreamMultimedia "dreambox-image-deb-dm920-20200617.tar" dann den Netzwerkbrowser installiert und mein FritzNas (cifs mount) eingebunden mit Benutzername und Password,

    hier erscheint der Fehler nicht, bei nicht vorhanden/abgesteckten Netzwerkkabel bootet die DM920 normal durch ohne delay!


    -- mit dem Merlin image "Merlin_OE-2.5-dm920-experimental-20200418.tar" benötigt die DM920 mit dem Netzwerkbrowser eingebundene FritzNas (cifs mount) bei nicht vorhanden/abgesteckten Netzwerkkabel für den bootvorgang ca. 120 sekunden


    fstab schaut in beiden images identisch aus!


    Vielleicht könnte sich das mal ein Admin oder Mod anschauen.

    ob es auch bei einem nfs mount auftritt kann ich nicht sagen da mir nur der cifs mount der Fritzbox zur Verfügung steht,

    falls mal jemand Zeit hat, wäre schön, wenn man das fixen könnten , thx

  • hast du nach den Neuflashen dann erstmal alle updates gemacht damit du auf dem letzten aktuellen Imagestand bist ?

  • hast du nach den Neuflashen dann erstmal alle updates gemacht damit du auf dem letzten aktuellen Imagestand bist ?

    mist, habe ich nicht! :wand:

    ich beide images dreambox-image-deb-dm920-20200617 und "Merlin_OE-2.5-dm920-experimental-20200418.tar" ohne update eingestellt und getestet

    kann ich morgen machen, heute komme ich da nicht mehr ran ;)

  • Da machen wir nichts dran, also muss es etwas anderes sein. Einziger Unterschied ist, dass wir samba server nicht vorinstallieren. Aber eben server nicht client