Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Update-Notifier und laufender Timer = Bootschleife

  • Nun ist es mir schon zweimal passiert, dass wenn der Updatenotifier sich meldet und ich brav ein Update durchführe und parallel noch eine Timeraufnahme (weekly) läuft, dass dann der Neustart der Box in einer Endlos-Bootschleife mit Greenscreen hängt.


    Crashlogs haben 0 Byte oder 274 Byte nur mit Headerinfo aber ohne Fehler


    Schalte ich die Box(8000) per Netzschalter aus, bootet sie sofort ohne Fehler.


    Läuft kein aktiver Timer, funktioniert das Update problemlos.

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • Wird ein Neustart nach dem Update gemacht, obwohl eine Aufnahme läuft? Wenn ja, ist das ein Enigma2-Bug, dass danach eine Bootschleife entsteht. Ghost weiß da aber bescheid.

  • Der Updater schlägt einen Neustart vor, zeigt aber die laufende Aufnahme nicht an bzw. prüft es nicht. Beim Neustart wird dann der Timer-Aufnahme Dialog angezeigt... Dadurch kam ich erst auf die Idee zu prüfen ob evtl eine Aufnahme läuft.

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • Ich habe halt "ja" gedrückt und der Bootvorgang wurde eingeleitet

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • Ah, ok :-)
    Also das liegt nicht am Updater, sondern an einem Enigma2-Bug, dass beim Start von Enigma2 und laufendem Timer ein Problem auftaucht...DMM weiß aber Bescheid, irgendwas will da nicht im Treiber oder c++ Code...

  • Das erklärt einiges .... hatte ich jetzt auch schon öfters!!! Bei einen reinen GUI Neustart kommt der Greenscreen!!


    Bei mir hat es geholfen, die Box kurz vom Strom zu nehmen und dann wieder neu gestartet!!!

  • Bei endlosen crashschleife:
    über ftp alle betroffene (laufende) timer auf 'disabled="1"' setzen. Dann die Box über den netzschalter ausschalten und nach ca. eine minute wieder anschalten.


    Um es zu meiden:
    VOR einem GUI-restart oder Box-neustart, alle laufende timer deaktivieren.
    Das betrifft nur vorprogramierte aufnahmen. Kurzfristige sind nicht betroffen (werden sowieso beim E2-resatrt gelöscht)


    Und ja, das ständige Deaktivieren und Aktivieren nervt extrem :grmml:


    ...oder man verwendet images die älter als 28.12.10 sind :(

    Duo2 /4xS2 /SSD160 /Flash: OpenPLi /MeoBoot-Images: VTi, PLi4, ViX, ATV...
    dm7080ssss /BA on SD/USB
    NAS: Qnap221 SSD1TB