Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Greenscreen nach Update vom 4. Februar 2014 (Skin-Fehler).

  • Hallo allerseits,


    nachdem ich heute das Merlin-Update vom 04.02.2014 () eingespielt habe, erhalte ich mit all meinen Custom Skins (Skin LN.HD-ME, MetrixHD.ME 8bit, Default-HD.grey.ME) einen Greenscreen. Nur der Default Skin funktioniert noch - zum Glück.


    Kann jemand anhand der Logs erkennen, wo der Fehler liegt und wie ich ihn beheben kann?
    Ich vermute, es hat was damit zu tun: "ImportError: No module named CaidDisplay"

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

  • Kann es sein, dass mir die Datei CaidDisplay.py im Verzeichnis


    /usr/lib/enigma2/python/Components/Renderer


    fehlt und ich deshalb den GS bekommte? Im oben genannten Verzeichnis habe ich nämlich die genannte Datei nicht. Kann mir diese jemand bitte zur Verfügung stellen?

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

  • so wird es sein ... warum die bei dir fehlt wird wohl dein Geheimniss bleiben.Mit den update hat das nix zu tun.

  • Wo kann ich die fehlende Datei CaidDisplay.py herunterladen? Ansonsten funktionieren ja meine Custom Skins allesamt bis auf weiteres nicht mehr. Kann mir jemand bitte die Datei auf die Schnelle hier anbieten als Anhang, falls es keine sichere Download-Möglichkeit gibt?


    @ dreagalli
    Edit: Mir fehlt nur noch "Caids.py". Immerhin ist alles andere bei mir auch vorhanden.

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von Franky ()

  • einfach irgendeine py kopieren und umbenennen und den Inhalt ersetzen.


    Diese Vorgehensweise hat leider nicht funktioniert. Vielleicht habe ich auch den falschen Editor benutzt.
    Könnte jemand bitte seine Version der Datei CaidDisplay.py und zur Sicherheit noch Caids.py hier im Thread als Datei im Anhang zur Verfügung stellen?


    Danke!

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

  • Franky : kein Plan was Du da angestellt hast (wahrscheinlich irgendeinen Skin installiert, welcher unsere Converter/Renderer verwendet, was alles durcheinander bringen kann...), aber ich würde auf keinen Fall Converter und Renderer von uns aus anderen Quellen nehmen, insbesondere von denen, wo wir noch nicht mal gefragt wurden, ob dort Sourcen von uns überhaupt abgelegt werden dürfen. ;) Du weißt doch gar nicht, ob da was am Ende noch verändert wurde...


    Mach im telnet ein:


    Code
    1. opkg update
    2. opkg install enigma2 --force-reinstall


    Dann wird bei Dir wieder eine 100% Merlin-Enigma2-Version auf der Box installiert, und deine fehlenden Sourcen sind dann auch wieder da...

  • @ Dr.Best


    Ich werde den Befehl nachher testen und dann berichten; leider startet gleich ein Timer für meine bessere Hälfte.

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

  • Dass wir hier im Board auch immer mit den "schlechten" Hälften zu tun haben :think: :D

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • @ Dr.Best


    Es hat geklappt! Nach dem o.a. Befehl & Reboot ist jetzt zwar nur die fehlende Datei Caids.py hinzugekommen, es reicht aber aus; da all meine Custom Skins keinen GS mehr erzeugen.
    Danke.

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

  • @dreagalli: weltklasse. irgendeine quelle angeben (wie kommst du eigentlich auf die idee, dass wir diese datei entfernt hätten?) und danach wundern sich alle, dass die skin-einstellungen im dreamcc ohne wirkung bleiben.

  • Wie nur die fehlende Caids.py?
    Was ist denn mit CaidDisplay.py? Fehlt die immer noch?


    Ja, die fehlt seltsamerweise immer noch, zumindest im Verzeichnis /usr/lib/enigma2/python/Components/Renderer finde ich sie nicht.


    Im Verzeichnis /usr/lib/enigma2/python/Components/Converter ist aber diese Datei zu finden. Ob sie schon vorher da war, kann ich nicht mit Bestimmtheit sagen; der Zeitstempel der Datei lässt es aber nicht vermuten.

    Pay-TV: Sky Komplett HD & TV Vielfalt HD | Receiver: Dreambox 7080HD | TV: Panasonic TX-P55VT50

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von Franky ()

  • Bitte schön. Das .txt entfernen!
    Die CaidDisplay.py kommt in das Verzeichnis /Converter/, und Caids.py in /Renderer/

  • @dreagalli: weltklasse. irgendeine quelle angeben (wie kommst du eigentlich auf die idee, dass wir diese datei entfernt hätten?) und danach wundern sich alle, dass die skin-einstellungen im dreamcc ohne wirkung bleiben.


    Wie ich auf die Idee komm? Ganz einfach. Weil sie bei mir auch fehlt. Dachte die fehlt mit Absicht.
    Das irgend ein Skin die Datei entfernt, kann ich mir nicht vorstellen. Es werden ja nur Skincompents und selbst mitgebrachte Converter/Renderer entfernt.
    Selbst wenn ein Skin die py mitgebracht hätte, wäre die Installation fehlgeschlagen, da sie schon vorhanden ist.


    Zum Testen kommen bei mir nur die 3 Skins in Frage: ModernMetrix, Holo und Nuke. Andere Skins hatte ich seit dem neu Flashen nicht auf der Box.


    Aber wie gesagt, kann ich mir nicht vorstellen, daß irgend ein Skin das war. Evtl. ist bei einigen das Update nicht sauber gelaufen. Naja, egal. Brauch die py nicht für meinen Skin.