Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

[Enigma2-Plugin] VideoDB für DM900/DM7080/DM820/DM52X : Update 04.10.2018

  • Hast du sie korrekte Fernbedienung in den Einstellungen von enigma2 ausgewählt?

  • Jepp, gerade nochmal kontrolliert. Die ohne separate Audio-Taste, aber mit separater Play-Tastenreihe.


    Im normalen Movie-Player funktioniert gelb (für Audio) ja auch. Im VideoDB-Player leider nicht.

    Sony KD-75XE9405 + Samsung LE37B554

    DM920 + 8000 + 520 + NAS S1813+ (30 TB)

    VF Kabel + Premium HD + Sky Welt/Film/HD

  • Hallo!

    Ich wollte gerade für meine Videodb eine 2. Box einbinden, aber der screen sieht nicht so aus wie er sollte (siehe Anhang). Der Text ist abgeschnitten und die gelbe Taste zum Hinzufügen reagiert auch nicht. Festgestellt habe ich das mit dem Zombi-Shadow-FHD Skin, aber mit Default-FHD Skin sieht es genauso aus.

    Was ist zu tun?

    LG

    G

  • Wenn dann bitte auch ne screen vom default-skin ...

    Ansonsten muß das zombi in seinen skin bitte anpassen wenn die Schrift im feld zu lang ist.


    Gelbe Taste - nachschauen ob GP4 was überschreibt ??

    Ansonsten wie oben gesagt, keiner nutzt von uns GP4 damit können wir dir auch nicht helfen.

  • Die Frage ist: welches Image ist drauf? zombi hat VideoDB mit grosser Wahrscheinlichkeit nicht geskinnt. Wir greifen in unserem Image korrigierend ein bei separation, beim Default greift der von zombi definierte Standard für seinen skin

  • Doch ich hab die VideoDB geskinnt und ja ich hab den Einhängepunkt Screen beim letzten up mit schmaler gemacht und im neuen Design (so wie auf Bild1),ich hab hier nicht so breite Infos drin und dachte das es im neuen Design besser aussieht als so breit.

    Ich nutze die VideoDB nicht wirklich viel ,daher kann ich da wenig Aussage treffen was wie wo geht ,ich hab den Screen jetzt einfach mal wieder breiter gemacht (so wie auf Bild2 ) ,gefällt mir zwar nicht wirklich aber wenn da lange Infos kommen bei einigen dann mach ich das gern auch wieder so breit.

    Was das mit dem Hizufügen (gelb angeht ) das geht hier auch ohne Probleme ,das einizige wo es nicht geht ist die one ,da sind die Einträge auch blau (das hat sicher was zu bedeuten (eventuell weil auf dieser Box die Einhängepunkte sind wo gescannt wurde und die anderen Boxen da drauf zugreifen) .

    Wie gesagt da macht auch GP nix mit ,das ist sicher ne Funktion von der VideoDB und das kennt ihr denke besser als ich ,ich hab da nicht wirklich große Ahnung von was da die VideoDB wie kann.

    screenshot.jpgscreenshot.png

  • Oder einfach in der /etc/enigma2/settings selber manuell eintragen:


    Pfad bei mir zur VideoDB auf einer 2. Box:


    Code
    1. dm900.fritz.box:/data/VideoDB 2659840 1738400 766624 70% /data/VideoDB

    Eintragen in /etc/enigma2/settings


    Code
    1. systemctl stop enigma2
    2. ... editiere den Eintrag mit DEINEM Mountpunkt an der Stelle "config.plugins.videodb.databasepath=/data/VideoDB"
    3. systemctl start enigma2
  • siehe oben - bei Zombi geht es mit GP4 , bei allen anderen mit merlin geht es ...

    Also muß es was spezielles bei dir sein.

    Ohne das wir wissen was du sonst noch installiert hast - wie sollen wir dir da helfen ?

  • Danke für Eure Kommentare.

    Anbei die screenshots mit dem default-FHD-skin. Mit dem Default-Skin funktioniert es, aber die gelbe Taste ist trotzdem ohne Funktion.


    Die gelbe Taste ist dynamisch gesetzt. Das heißt nur wenn für einen angegebenes Verzeichnis noch kein "points to" existiert kannst Du das setzen. Des Weiteren musst Du das aber von der Box machen, auf welcher Du den analogen Pfad setzen willst.

    Klingt alles komplizierter als es ist. :)

    Schau dir mal das How to an: https://board.dreambox.tools/i…cle/90-howto-zur-videodb/


    Da steht das ein bisschen besser von mir beschrieben.


    Videodb default.jpg


    Bei deinem Screenshot sieht man, dass du den Eintrag "/media/Serien" (also der erste Eintrag) sowohl bei deiner zweiten DM7080(?) als auch bei der 920 bereits gesetzt hast. Deswegen kommt bei Dir kein "hinzufügen" mehr auf gelb, dieser Eintrag wurde bereits für alle gesetzt. ;)

  • Anleitung nach meiner Konfiguration:


    Ich habe auf dem Server (DM900) die VideoDB im Pfad /data/VideoDB (so bleibt die Datenbank auch nach einem evlt. neu Flashen erhalten).

    Anlegen des Ordners VideoDB auf dem Server:


    Code
    1. mkdir /data/VideoDB

    Dann diesen Pfad im Setup der VideoDB auswählen und die Datenbank per VideoDB erstellen lassen.


    Auf dem Server (DM900):


    Code
    1. In /etc/exports:
    2. /data/VideoDB 192.168.188.0/24(rw,all_squash,anonuid=0,anongid=0,no_subtree_check,async)

    Auf der 2. Box (eine DM520 - spielt aber keine Rolle) benutze ich den gleichen Pfad als Mountpunkt:

    Code
    1. mkdir /data/VideoDB
    2. In /etc/fstab:
    3. dm900.fritz.box:/data/VideoDB /data/VideoDB nfs defaults 0 0

    Keine Symlinks oder andere "Verbiegungen" benutzen!


    Dann diesen Pfad auf deiner 7080 auswählen.


    Hinweis: Die Datenbank muss NICHT dort liegen, wo auch die Filme/Serien liegen! Wenn die DB quasi im RAM (/data) liegt, dann hat das auch den Vorteil, dass beim stöbern in der Datenbank NICHT die Festplatte (oder das NAS) erst hochfahren muss, um die DB lesen zu können.

  • Ja, so wird das gemacht. :)

    Ich setzte auch nirgends in der VideoDB Symlinks oder was auch immer. :) Im Prinzip hast Du die Vorgehensweise genau so noch mal erklärt wie es gehen soll.

    Und ich habe auch die Datenbank bei mir in /data auf einer meiner Boxen liegen, da gehört die auch hin (unter dem Aspekt natürlich, dass die Box immer erreichbar ist!).

  • Danke für die ausführliche Beschreibung! das howto zur Videodb kenne ich natürlich.

    Meine /etc/exports und /etc/fstab Einträge sehen eigentlich genauso aus und ich sehe auf der DM7080 (Client) auch den freigegebenen Ordner /Videodb der DM920 (Server). Ich kann die Datenbank auf der DM7080 auch aufrufen und durchscrollen, aber die Wiedergabe funktioniert eben nicht. Irgendwas stimmt mit den mountpoints nicht.

    Symlinks habe ich auch keine.


    Code
    1. /etc/exports der DM920UHD (192.168.1.8)
    2. /data/Videodb 192.168.1.0/24(rw,no_root_squash,no_subtree_check,nohide)
    3. /media/hdd/movie 192.168.1.0/24(rw,no_root_squash,no_subtree_check,nohide)


    Code
    1. /etc/fstab der DM7080 (192.168.1.11)
    2. /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
    3. /dev/disk/by-uuid/56cbc9a1-50c2-42f8-b60e-c5e6c7b0641e /media/hdd auto auto,nofail 0 0
    4. 192.168.1.8:/data/Videodb /data/Videodb nfs x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,ret rans=1,async,nolock,noauto,nofail,soft,rw 0 0
    5. 192.168.1.8:/media/hdd/movie /media/movieDM920UHD nfs x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,t imeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw 0 0


    Videodb3.jpg


    Lg

    G

  • Wenn Du auf der DM900 die Filme unter /media/hdd/movie hast, dann scanned/findet VideoDB die auch dort und speichert diesen Pfad in der Datenbank.

    Du solltest auf der 7080 auch genau diesen Pfad als Mountpunkt verwenden:


    Code
    1. 192.168.1.8:/media/hdd/movie /media/hdd/movie nfs x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,t imeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw 0 0

    Woher soll die VideoDB Datenbank "wissen", dass der Pfad auf deiner 7080 ein anderer ist?


    Grüße