Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

[Enigma2-Plugin] VideoDB für DM900/DM7080/DM820/DM52X : Update 07.08.2017

  • Ich habe die Datenbank auf einem USB Stick am NAS mal getestet, konnte die Filmtitel zwar auf beiden Boxen sehen, jedoch konnte ich auf einer der Boxen nicht abspielen, wenn ich ein Film markierte und OK drückte passierte nichts. Mache ich ein Fehler?


    Edit: Was bedeuted immer erreichbar, das NAS läuft nicht immer, reicht es wenn man VideoDB benutzt oder wirklich immer?

  • Edit: Was bedeuted immer erreichbar, das NAS läuft nicht immer, reicht es wenn man VideoDB benutzt oder wirklich immer?


    Wenn die Dreambox bootet, also Enigma2 startet (auch bei GUI Neustart), werden Informationen von der Datenbank gelesen, die wichtig sind für den laufenden Betrieb des Plugins. Wenn nun die Datenbank nicht erreichbar ist ist die VideoDB also nicht richtig beim Starten von Enigma2 initialisiert, und somit nicht richtig funktionieren.

  • Danke für die Hilfe


    Ok, Boxen starten wenn NAS läuft, dann werde ich mal testen. Kann ich dann die Datenbank einer der Boxen auf den USB Stick kopieren damit es dann auf beiden Boxen funktioniert? Oder muss ich eine neue Datenbank erstellen?

  • Du kannst die bestehende Datenbank einfach verschieben (inkl. der images). Auf der anderen Box musst du dann eben noch die Mountpfade anpassen.


    Hast du gar kein Gerät zu Hause, das 24/7 läuft und einen USB-Stick aufnehmen kann? z.B. Fritz!Box?

  • Genau. Du brauchst einfach ein Medium, dass in jedem Fall verfügbar ist, wenn eine der beiden Boxen bootet und wenn du die VideoDB nutzen willst. Wie das dann genau gemountet ist, ist egal. Bei der Fritzbox geht es halt mit der FritzNAS Funktion sehr einfach mit einem CIFS-Share.


    Die video.db musst du dann auf beiden Boxen in den Einstellungen natürlich noch einstellen. Am Besten fängst du mit der Box an, auf der du VideoDB bereits nutzt :)

  • irgendwie komme ich nicht weiter.


    habe eine DM920 mit 2TB Platte neu aufgesetzt, mit autonas die Qnap und Fritznas gemountet.

    Schaue ich auf media/nas habe ich die Ordner

    Dreambox (Filmverzeichnis der Qnap),

    Fritznas (USB Stick an der Fritzbox 7390)

    USBDisk1 (USB Stick an der Qnap eingesteckt)

    auf die Ordner habe ich vollen zugriff und sehe alles.

    In der Filmliste habe ich ein Symlink Dreamnas auf das Filmverzeichnis der Qnap.


    Wenn ich nun ein Scan der TV Serien mache auf der Qnap oder in einem Serienordner in der Filmliste (interne HDD), so sehe ich im Scanfenster die Serientitel und was mit der Filmdatenbank durchlaufen bist die Meldung fertig kommt. Wenn ich nun auf die Log datei gehe ich schauen will was gescannt oder nicht zugeordnet wurde, so habe ich beides leer, also keine Infos.

    Will ich nun mit VideoDB auf den TV Serien schauen, so kommt ein Fenster mit der Meldung keine Serien in der Datenbank gefunden wurde und ich scannen soll.


    Was kann da faul sein? Habe VideoDB schon deinstalliert wieder installiert und es will einfach nicht.


    Danke schon mal für eure Unterstützung

  • Hallo,


    genau das habe ich auch, ich dachte ich bin zu blöd und habe das Image mindestens 5 mal neu installiert.


    Also zur Hardware:

    DM920

    Qnap NAS mit Ordnerstruktur / Filme /Serien

    wenn ich scanne sieht es erst so aus als ob etwas gemacht wird aber es ist nichts in der Datenbank.

    Wenn ich gezielt mir eine Datei *.mkv aussuche dann schreibt er diese in die Datenbank und die Datei ist grau.

    Alle anderen Dateien in den Unterordnern sind weiterhin weiss, al ob diese nie angefasst wurden.

    Also manuell geht es aber per suche in Unterordnern nicht.

    Warte auch auf eine Lösung.


    Piggy

  • Code
    1. Error-message:[Errno 2] No such file or directory: '/media/Serien2018/2018/The Gifted/Season 1/The.Gifted.S01E01.GERMAN.DL.1080p.HDTV.h264-ACED/.@__thumb/adefaultThe.Gifted.S01E01.GERMAN.DL.1080p.HDTV.h264-ACED.mkv'

    Das hatten wir schon mal. Deine QNAP legt irgendwelche komischen Verzeichnisse mit Dateien an, damit kommt mein Scanner nicht klar.

    Ich glaube Du findest hier im Thread eine Lösung, ich weiß es leider nicht mehr, wie wir das damals gelöst hatten.