Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Nuke.FHD Lite 7.5.1 -> Full HD Skin für OE2.2 DMM-Images und (optional installierbarem) GP3.3

  • Nuke.FHD Lite -> Full HD Skin für OE2.2 Dreamboxen mit DMM Image


    1. generische Version des Nuke.FHD Skins, welche im Gegensatz zu Nuke.FHD auf allen OE2.2 Images läuft


    Installationshinweise


    Wenn nur ein original DMM Image ohne GP3.3 benutzt wird, müssen manuell vorher drei skincomponents installiert werden:


    • enigma2-plugin-skincomponents-eventposition
    • enigma2-plugin-skincomponents-runningtext
    • enigma2-plugin-skincomponents-eventlist


    Sollte bereits das GP3.3 auf der Dreambox aktiv sein, werden diese skincomponents bei Installation des Skins automatisch mitinstalliert



    Einschränkungen gegenüber der Nuke.FHD Version für Merlin Images




    • Keine Merlin Extensions



    info.pngchsel.pngaudio.png1.png

  • Nuke.FHD Lite 7.4.6 (Beta) -> Full HD Skin für OE2.2 Dreamboxen mit DMM Image und (optional installierbar) GP3.3 Support


    Generische Version des Nuke.FHD Skins, welche im Gegensatz zu Nuke.FHD auf allen OE2.2 Images läuft


    Installationshinweise


    Wenn nur ein original DMM Image ohne GP3.3 benutzt wird, müssen manuell vorher drei skincomponents installiert werden:



    • enigma2-plugin-skincomponents-eventposition
    • enigma2-plugin-skincomponents-runningtext
    • enigma2-plugin-skincomponents-eventlist



    Sollte bereits das GP3.3 auf der Dreambox aktiv sein, werden diese skincomponents bei Installation des Skins automatisch mitinstalliert



    Einschränkungen gegenüber der Nuke.FHD Version für Merlin Images




    • (Noch) kein Theme Support mittels MerlinSkinThemes
    • Weniger Anzeigen in Infobar, About etc
    • Beta. Schon benutzbar, aber es wird daran gearbeitet :D


    Änderungen:



    • GP3.3 -> Bilder Browser, Video Browser und Musik Browser nun mittels components in FHD-adäquater Darstellung
    • AMS -> Designanpassungen (kleinere Progessbar, Schriftgrössen, Anordnungen der Widgets ....)
    • Movieplayer Infobars -> Designanpassungen (Playersymbole transparent ...)
    • Kontextmenüs, Menüs -> Fixes (wraparounds, Schriftgrößen, Alignments)
    • Cutlisteditor -> Sprungmarken Textgröße
    • SeconfbarInfo -> ZPosition nach vorne verschoben, damit der Screen sich vor andere evt geöffnete Einblendungen (Tunerstate etc) legt
    • InfoBarTunerState -> Position verschoben um Kollisionen mit anderen Screens wie SecondInfoBar zu umgehen
    • AMS -> Einbau der restlichen, fehlenden Screens (Backuprestore, AdvancedMovieSelectionAboutDetails, AdvancedMovieSelection1 ...)
    • RadioInfobar, ChannelSelectionRadio -> (nichtalternativer Radiomodus) durch die Screens bedingte Crashes gefixt und bei der Gelegenheit bemerkt, das dieser Modus im aktuellen DMM Image gerade mal defekt ist: "--> AttributeError: 'ChannelSelectionRadio' object has no attribute 'returnValue'"


    ... und wie immer eine Menge Dinge, die ich schon wieder vergessen habe


    4_ams.png4_mpex.png



    In der nächsten Version kommen dann weitere (optionale) GP3.3 Enhancements wie Sensorfelder in der Infobar dazu. Und dann schau ich mal zu nn² rüber, was diesbezüglich noch fehlt :undweg:


    Download im 1. Post dieses Threads.

  • Läuft! Danke, ist irgendwie wie Heim kommen. Der Skin war unter Merlin mein Favorit und jetzt auch wieder. Trotz GP3.3 und aktuellen DMM-Image musste ich die Skincomponent-runningtext manuell installieren. Bin auf die weitere Entwicklung gespannt.

  • Läuft! Danke, ist irgendwie wie Heim kommen. Der Skin war unter Merlin mein Favorit und jetzt auch wieder. Trotz GP3.3 und aktuellen DMM-Image musste ich die Skincomponent-runningtext manuell installieren. Bin auf die weitere Entwicklung gespannt.


    Nach Hause kommt man, wenn man ein Merlin installiert hat. :scream: Meine Exkursion in fremde Gefilde ist fast beendet. Nur noch schnell die Infobar/ChannelSelection für GP3.3 feddich machen :undweg:

  • Nuke.FHD Lite 7.5.0 -> Full HD Skin für OE2.2 Dreamboxen mit DMM Image und (optional installierbar) GP3.3 Support


    Generische Version des Nuke.FHD Skins, welche im Gegensatz zu Nuke.FHD auf allen OE2.2 Images läuft


    Installationshinweise


    Wenn nur ein original DMM Image ohne GP3.3 benutzt wird, müssen manuell vorher drei skincomponents installiert werden:




    • enigma2-plugin-skincomponents-eventposition
    • enigma2-plugin-skincomponents-runningtext
    • enigma2-plugin-skincomponents-eventlist




    Sollte bereits das GP3.3 auf der Dreambox aktiv sein, werden diese skincomponents bei Installation des Skins automatisch mitinstalliert




    Änderungen:




    • Add: MerlinSkinThemes Support - die volle Dröhnung (7 Themes, diverse Infobars, ChannelSelections ...)
    • GP3.3 -> Diverse Screen Fixes
    • GP3.3 -> Add Support für verschiedene Schriftgrößen in der Kanalliste
    • AMS -> fehlende Screens hinzugefügt, Fixes
    • GP3.3 -> optionale Infobar mit Sensorsupport (zuschaltbar in den MerlinSkinThemes -> "Infobar" -> "GP3.3 Standard"


    gp_infobar.png



    ... und wie immer eine Menge Dinge, die ich schon wieder vergessen habe



    alle_themes.jpg





    Wichtig:


    Im Gegensatz zum Merlinskin Nuke.FHD kann man hier durch unbedarftes Auswählen ungeeigneter Optionen in MerlinSkinThemes die Dreambox ZUM ABSTURZ bringen. Stellt sicher, das ihr nur für euer Image geeignete Screens um/anschaltet.


    Beispiel: Habt ihr ein Merlin-Image, dann führt die Auswahl einer GP3.3 Infobar ZUM ABSTURZ
    Beispiel: Habt ihr ein DMM Image (ob mit oder ohne GP3.3 ist egal), dann führt die Auswahl eines Merlin Screens ZUM ABSTURZ


    Die Defaults des Skins sind so gewählt, das er nach Installation erst einmal auf jedem OE2.2 Image läuft. Ihr geht danach also in die MerlinSkinThemes und wählt als erstes ein euch genehmes Design aus (es gibt 7):


    mst1.png



    Danach könnt ihr eine euch genehme Infobar etc auswählen. Hier darauf achten, das die Auswahl zu eurem Image passt. Sonst: Absturz nach Enigma-Neustart.


    mst2.png


    Wie gesagt: Willkommen in der potentiell gefährlichen Welt der Nicht-Merlin-Images. Wenn sich herausstellt das die User mit dieser Vielfalt überfordert sein sollten, dann speck ich ab :undweg:


    Und ja: Dies ist nur eine Lite Version. Ein kleiner Ausflug zu den Mitbewerbern, solange es hier etwas langsamer als gewöhnlich zugeht. Die volle Dröhnung Neuerungen gibts mit Erscheinen des neuen Merlin Images :D



    Download im 1. Post dieses Threads.

  • Der Lite ist jetzt ja garnicht mehr so Lite :D


    Ich habe noch einen Crash gefunden. Grafischer Multi-EPG startet nicht, nach ner Weile kommen Spinner und dann ein Crash. Mit dem Default-Skin passierts nicht ;)

  • Ich wollte deinen schönen Skin über Gp3.3 installieren, habe die Box neugestartet, aber erscheint nicht bei den Skins


    Lösung gefunden.... Running Text wurde nicht mitinstalliert, musste manuell installiert werden

  • Der Lite ist jetzt ja garnicht mehr so Lite :D


    Ich habe noch einen Crash gefunden. Grafischer Multi-EPG startet nicht, nach ner Weile kommen Spinner und dann ein Crash. Mit dem Default-Skin passierts nicht ;)


    Der ist nicht nur nicht Lite, der ist sogar voll fett geworden. Aber erzähl mal Deiner Uschi, das sie im Laufe der Jahre häßlich und aufgepumpt geworden ist .... nein, das Teil ist im besten Alter. :scream:


    Bug gefunden, wird heute ausgebaut :undweg:

  • Ich wollte deinen schönen Skin über Gp3.3 installieren, habe die Box neugestartet, aber erscheint nicht bei den Skins


    Lösung gefunden.... Running Text wurde nicht mitinstalliert, musste manuell installiert werden


    Komisch. Ich hab hier nur den DMM- und GP Feed auf der Box, und da wird mir runningtext mit aufgelistet:


    sc.JPG


    Das ist auch ein Elend mit den verschiedenen Feeds.

  • Ebenfalls unstable + GP3 und viel weniger Skin-Components. Und runningtext musste ich von Hand nachinstallieren :(


    Müsste man mal im IHAD nachfragen. Evtl. muss ich noch irgendeinen Feed aktivieren? "Extra Plugins" gibt es ja glaube ich nicht mehr.

  • Der Lite ist jetzt ja garnicht mehr so Lite :D


    Ich habe noch einen Crash gefunden. Grafischer Multi-EPG startet nicht, nach ner Weile kommen Spinner und dann ein Crash. Mit dem Default-Skin passierts nicht ;)


    Gefixt. Da waren noch zwei schöne Merlin Extensions drin .... Entweder die skin.xml austauschen, oder bis zum nächsten Update warten.

  • Gabs da nicht mal was?
    Ich meine mal gesehen zu haben,
    daß man eine Datei im Skin haben kann, die vor, während der Installation und jeweils eine, die beim oder nach dem Deinstallieren ausgeführt.
    Hab mal in einem MEPG Skin sowas gesehen.
    Da wurde automatisch abgefragt, ob Merlin oder nicht.
    Könnte man in den Skin einfliesen lassen, dann hast du weniger Aufwand bei Änderungen.
    Dann wird automatisch das Image abgefragt und das richtige genommen. Bloß so ne Idee. :-)

  • Man kann das per Plugin machen, ja. Alles eine Frage des Aufwandes. Nur: Einerseits wollen die Leute immer mehr Features. Andererseits kommen sie dann damit nicht mehr klar. Oder meckern und wollen eine maßgeschneiderte Lösung ("ich hab ein Newnigma Image, was interessiert mich der GP Scheiss, das macht den Skin nur fett" ...)


    Und auch ein automagisches Plugin würde John Doe nicht ausreichen ("warum muß dieser Kackskin nach jedem Update erst im DMM Modus starten und dann konfiguriert werden, ich will SOFORT meine Super Duper GP3 Infobar" ...)


    Der Skinner/GUI Designer/Usuability Manager ist eh immer am Ende der Nahrungskette und per se das Arschloch (Programmierer programmieren, Skinner "basteln"). Betrachten wir also diese Version als (funktionierende) Interimslösung, als proof of concept ohne den masochistischen Anspruch auf jeden Wunsch eingehen zu müssen. Ich mache gerade Ausflüge zu den anderen Images, das macht Spaß, ich guck mir mal an was die so anbieten, und ihr kriegt nebenbei noch einen dort funktionierenden Skin ab. Bald gehts wieder heim, dann wird es wieder kuschelig ohne "lite" hinten dran :D

  • Ich habe heute mal das DMM Image mit GP3.3 ausprobiert. Natürlich mit Nuke :anbet:. Super Arbeit.


    Ich habe festgestellt, dass nach dem benuzen vom Mediaportal das Datum nicht mehr auf englisch ist.

  • Tja, dafür gibt es mit dem aktuellen DMM Image wieder neue Fehler :scream:


    Beispiele gibt es viele. Am meisten nervt derzeit hier das Problem, das nach einem Boxenneustart/GUI Neustart Bei DVB-C (und NUR bei Kabeltunern) nicht getuned wird. Einmal danach zappen, und alles ist wieder gut. Aber das ist ein Aufnahme-Killer (sofern man am Kabel hängt) :undweg:


    dvbc.JPG


    Ich sollte wieder Bugreports an DMM schicken :undweg: Oder besser wieder schnell ein Merlin installieren.

  • Ich auch gleich. Newnigma spar ich mir, die wollen mich wohl nicht :D ... Dann bau ich mal einen Nuke.FHD (Merlin Version) mit den diffs von dieser Woche und gucke wieder TV statt ständig zu basteln. Beim GP3.3 nerven auch viele Dinge, die unsere Programmierer hier längst gelöst haben (Bsp: permanentes Einblenden der Infobar bei Drücken der "OK" Taste geht nicht, wenn gleichzeitig SecondInfobar installiert ist) ...


    Hier sitzen einfach die Perfektionisten. Da nehm ich einfach mal in Kauf, das unser Admin (der die Images baut) gerade mal Erholung braucht und es mit den Updates länger dauert :undweg: