Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Seit letztem Update kein FTP Zugriff mehr möglich

  • Hallo,
    Seit dem letzten Image update bekomme ich beim Versuch mit Filezilla wie immer zu verbinden nur noch folgende Fehlermeldung:
    500 OOPS: vsftpd: refusing to run with writable root inside chroot()



    Alle Versuche mit editieren der vsftpd.conf schulgen fehl bzw. zeigen keinen Effekt.
    Auch finde ich für die vsftpd kein downgrade einer älteren Version.


    Ich brauche Hilfe, ich hänge an dem Problem jetzt schon seit Stunden und habe mir zwischenzeitlich mit einer Änderung in der passwd auch mal das image komplett zerschossen.


    Verzweifelte Grüße :schwitz:


    Zur Info: ich nutze ein aktuelles Merlin OE2.2 auf einer DM820HD.

  • Für die DM820 gab es doch seit ungefähr Februar gar kein Update mehr. Womit hast du die vsftpd.conf bearbeitet?

  • Ist mir erst jetzt aufgefallen, da ich auf die Festplatte per Samba zugreife.
    Das Problem bestand schon bevor ich versucht habe in der conf was zu ändern. Editiert habe ich mit Nano bzw. Vi.

  • Soweit ich weiß wurde vsftpd seit Jahren nicht geupdatet:
    Hattest du denn vorher eine angepasste vsftpd.conf im Einsatz?


    Wenn nein, dann installiere doch einfach mal alles neu:

    Code
    1. install vsftpd --reinstall


    P.S.: Dein Profil ist nicht aktuell ;) Und ich habe den Thread mal in den richtigen Bereich verschoben.

  • Vielen Dank für den Hinweis,reinstall brachte aber leider keine Veränderung.das waren die letzten Zeilen der Ausgabe:

    Code
    1. NOTE: Performing useradd with [ --home-dir /usr/share/vsftpd/chroot --no-create-home --system --shell /bin/false --user-group vsftpd] and 10 times of retryWARNING: user vsftpd already exists, not re-creating itUnpacking vsftpd (3.0.2-r0.9) over (3.0.2-r0.9) ...Setting up vsftpd (3.0.2-r0.9) ...

    Habe bisher diverse Google-Suchen und die entsprechenden Lösungshinweise durchprobiert, habe versuchsweise einen neuen User angelegt und über diesen per FTP verbunden,aber es kommt immer die selbe Fehlermeldung.Einmal habe ich in der vsftpd.conf einen Schreibfehler drin gehabt, dann kam beim verbinden zum ftp der Hinweis, dass er dieses Argument nicht kennt. Die Datei wird also zumindest verarbeitet.Leider brachten die diversen Hinweise keinerlei Verbesserung und die "Lösung" die vorgeschlagen wir das Root Verzeichnis schreibzuschützen ist ja nicht wirklich eine Alternative.hat noch jemand eine Idee?Schon wieder das komplette Image von null neu einstellen ist immer so anstregend und zeitraubend. :kater2:Edith sagt, habe die Einstellung dank Hilfe gefunden, allerdings gibt es keinen Eintrag "DM820HD" hier sollte also entsprechend ergänzt werden :blinz:

  • Ich habe nur noch eine Idee, aber die wirst du nicht hören wollen und deshalb habe ich sie bisher nicht geschrieben ;)


    Neu flashen und möglichst wenig Einstellungen wiederherstellen :(