Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Merlin für DM920ultraHD (OE 2.5)

  • Ich habe im Movie Player (PVR Taste) das Merlin Kontextmenü aktiviert, und dann relativ schnell einen GS bekommen, weiß aber nicht bei welchem Menüpunkt das genau passiert ist. Hier das Crashlog:


    Traceback (most recent call last):

    File "/usr/lib/enigma2/python/enigma.py", line 7790, in __call__

    return ret(*args, **kwargs)

    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 51, in action

    res = self.actions[action]()

    File "/usr/lib/enigma2/python/Screens/MerlinContextMenu.py", line 170, in selectItem

    self["list2"].getCurrent()[2]()

    TypeError: 'NoneType' object has no attribute '__getitem__'

    -------

  • Gerade eben habe ich auf das 3. Programm des hr umgeschalten und enigma2 hat grundlos rebootet. Das hatte ich mit NN2 noch nie gehabt. Es gab wohl ein Segmentation fault.


    Entsprechender enigma2 log Auszug anbei.


    enigma2.log

  • Gerade eben habe ich auf das 3. Programm des hr umgeschalten und enigma2 hat grundlos rebootet. Das hatte ich mit NN2 noch nie gehabt. Es gab wohl ein Segmentation fault.


    Entsprechender enigma2 log Auszug anbei.


    enigma2.log

    Stürzt ab beim Schreiben in die EPG-DB. Eventuell etwas ungültiges drin. Sonst mal bei DMM posten.

  • Ich hab versucht anhand des Logs herauszufinden, was du gemacht hast. Ich kriegs nicht hin. Von daher wirds schwierig.

  • Ich hab versucht anhand des Logs herauszufinden, was du gemacht hast. Ich kriegs nicht hin. Von daher wirds schwierig.

    Ja, ich habe eben in dem Merlin Kontextmenü rum probiert, habe Verzeichnisse anzeigen aktiviert, habe Statusfarben anzeigen aktiviert, dann bin ich vermutlich von der lokalen Disk auf meine Disksation Freigabe gegangen. Irgendwann wollte ich erneut in den Menüpunkt "Erweiterungen" des Melin Kontextmenüs gehen, und da passierte dann nichts (sprich es kamen keine Menüpunkte, auch nicht leer wenn man nur einen Folder ausgewählt hat und somit keine Menüpunkte zur Verfügung stehen, es war wie wenn man nicht auf "Erweiterungen" gedrückt hätte). Und irgendwann kurz darauf kam der GS.


    Falls es wieder passieren sollte, versuche ich das noch mal weiter einzugrenzen.

  • Genau für das reparieren einer kaputten epg.db war dre ja so nett und hat das Zurücksetzen auf eine leere epg.db ins EPGRefresh reingemacht (bei den erweiterten Einstellungen im Plugin kann man es aufdrehen), und da die leere epg.db mit sqlite angelegt wird muss es auch als dependency dabei sein ... hatten wir im Plugin vergessen, sorry.

  • Super Arbeit, vielen dank an alle Entwickler.


    Für den Skin lt6.hd.mod fehlt noch eine abhängigkeit


    enigma2-plugin-skincomponents-refstring_1.0-r1.0_all.deb


    Besten dank für ein Upload

  • Danke für die tolle Arbeit. Der Umstieg von meiner 7080 zur 920 hat super schnell funktioniert. HD01 und S*Y laufen wie geschmiert. :klatsch::klatsch::klatsch::thumbup:

  • Auch von mir vielen Dank für das Image, drauf ist es, aber bin noch nicht groß zum testen gekommen.

    Aber ich denke heute Abend oder morgen wird die neue 920er meine 7080 ersetzen :)

  • Hab geduldig gewartet und mit meiner neuen 920 er bis jetzt mit allen anderen zur Verfügung stehenden Images herumexperimentiert. So jetzt nun endlich wieder zum Merlin, das schon seit zwei Jahren sehr zur Zufriedenheit auf meiner 7080 werkelt.


    Vielen Dank!:thumbup:

  • Hay

    Ich möchte mich in derer einreihen die das auf der DM920 installiert haben.


    Danke an alle die Mitgewirkt haben.

    mfg
    mike

    Onkyo AV TX-NR626
    Samsung 65" JS9590 SUHD
    NAS -->QNAP TVS-EC1080 --> 10x Western Digital WD40EFRX 4 TB --> ALLES

  • alles top! Herzlichen Dank für das Image

    --------------------------------------------------------------------------------
    DM920, DM8000
    Panasonic TX-43CXW754
    Panasonic SC-ALL30+2x SC-ALL2
    Wavefrontier t55
    8°w, 4/5°w, 0,8°w, 4,8°e, 9°/10°e, 13°e, 16°e, 19°e, 23°e, 28°e
    Standort Wien
    -------------------------------------------------------------------------------

  • Moin


    nochmal zu GM Beitrag zu "epg.db"


    hab jetzt mal nachgeschaut , die epg.db ist bei mir bereits auf 19.3 mb angestiegen. Auch nach löschen und Neustart bleibt die Größe der epg.db gleich und steigt täglich um 3-5 mb.

    bei einem Alten Images gibt es die epg.db nicht , dort befindet sich epg.dat -diese ist dort ca. 4.2 mb


    liegt hier ein Bug vor ?


    PS: es tritt auf allen OE2.5 Images auf Egal ob es 520,900 oder 920 ist