Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

NFS Shares richtig einbinden

  • Hallo Zusammen,


    habe erst seit kurzem einen Dreambox 920 und versuche gerade einen NFS Share einzubinden. Kenne mich nicht sehr gut damit aus - vielleicht kann mir jemand helfen. OS ist das aktuelle OE2.5 aus dem Mai.


    Auf meinem NAS habe ich einen NFS Share angelegt. Zum Test habe ich von einem Debian 9 System den Share gemountet und getestet ob alles funktioniert, Das sah so aus:


    Code
    1. sudo mount -t nfs 192.168.27.10:/mnt/LPS/aufnahmen /home/sov/dream/


    Ich kann unter diesem Verzeichnis beliebig Verzeichnisse anlegen, Dateien löschen, umbenennen oder kopieren. Sollte alsop eigentlich alles passen.

    Als nächsten Schritt habe auf meiner Dream über die Netzwerkfreigabe den SHare gesucht - tauchte auch auf und habe diesen mit folgenden Optionen eingehängt (siehe Screenshot)


    Na prima - also dann das Aufnahmeverzeichnis angepasst und hier bekomme ich dann folgende Meldung (siehe Screenshot)


    Nun bin ich mir nicht ganz sicher auf welcher Seite ich etwas tun muss, Dream oder auf meinem NAS. Theoretisch kann ich ja auf den Share zugreifen und auch alles löschen und erstellen also vermute ich dass i9ch irgendetwas auf der Dreambox vergessen habe.

    Jemand eine Idee?


    VG S

  • Information was du für ein NAS hast wäre sicherlich hilfreich ;)

  • Hi,


    sorry ich dachte das wäre nicht so wichtig da der Share unter einem Linux ja funktioniert. Wohl falsch gedacht :-) Es handelt sich um ein Freenas 11.1. Dort läuft ein NFS Dienst.

    NFSV4 ist nicht aktiv (wobei ich das testweise mal aktiviert habe hat aber keinen Unterschied für die Dream gemacht.


    Welche Infos benötigt ihr im Detail von dem Freenas?


    VG S

  • Hi,


    also was ich gerade noch ausprobiert habe: Ich habe mich per SSH auf dei Dream eingeloggt und dort manuel gemounted mit


    Code
    1. mount -t nfs 192.168.27.10:/mnt/LPS/aufnahmen /mnt/

    Dann habe ich das Verzeichnis /mnt/ als Standardvideoverzeichnis und Timeshift Verzeichnis verlinkt (Unter den Einstellungen auf der Dream). Das klappt problemlos.

    Gibt es denn eine Möglichkeit das einfach permanent so zu hinterlegen? Wäre doch das eifachse oder komme ich da mit irgendwelchen Systemprozessen der Dream in Konflikt?


    VG S

  • Permanent hinterlegen in:


    /etc/fstab


    Code
    1. 192.168.178.10://mnt/LPS/aufnahmen /media/nas/videos_hdd1 nfs tcp,x-systemd.automount,x-systemd.idle-timeout=60,x-systemd.device-timeout=2,nolock,rw,timeo=2,retry=0,retrans=1,soft,noauto,vers=3 0 0


    Zielverzeichnis des Mounts ist im Beispiel "/media/nas/videos_hdd1" und muss vor dem Mounten angelegt sein (existieren)

  • Hallo nochmals,


    vielen Dank das mit der FSTAB hat geklappt :-) So ist das Prima.


    Nur so aus Interesse: Gibt es eine Übersicht bzw. Beschreibung der ganzen Parameter die da mit angehängt sind?



    Über SSH konnte ich nicht mal das Verzeichnis "aufnahmen" betreten (Verzeichnis existiert nicht) welches vom Netzwerkmanager angelegt wurde. Nachdem ich die FReigabe wieder entfernt habe kann ich über SSH zumindest in das Verzeichnis. (Ist aber natürlich leer)

    Irgendwas scheint da also mit dem Netzwerkmanager nicht ganz hinzuhauen.

  • Mounten über diverse GUI-Versuche diverser Dreamboxbetriebssysteme war schon immer eine Krücke. IMHO kriegen die das nie so fehlerredundant hin, das es jemals zu empfehlen ist.


    Bspw. wird standardmäßig bei NFS Mounts UDP genommen, was Unfug ist. Das war zu Zeiten von dBox Böxchen vielleicht ein Performancevorteil. Auf aktuellen Boxen ist UDP eher eine Spaßbremse (keine Fehlerkorrektur, viele Soho Netzwerke sind mit UDP überfordert ...).


    "vers=3" Musst du auch immer nachtragen. Die Dreambox klappert sonst die Mountversuche von Version 4 bis 1 runter, das dauert. Aktuell gebräuchliche NAS supporten aber nun mal NFS Version 3.


    Wenn ich den Spass im GUI per Fernbedienung (!) eh nachtragen muß, dann mach ich das doch lieber gleich im Schnellgang, indem ich die fstab direkt editiere.


    Eigentlich müßten im GUI Mounter der Dreambox nur mal sinnhaftige Presets rein. Betonung liegt auf sinnvoll. :D

  • Ich habe meine automounts jetzt auch nach diesem Muster in der fstab umgebaut. Funktioniert soweit ok. Allerdings habe ich bisher weder Vor- noch Nachteile festgestellt.

    Dennoch, vielen Dank für den Hinweis!

  • Nun, zwischen Perfektion und "funktioniert irgendwie" gibt es schon raffinierte Unterschiede. Die zeigen sich nicht nur in Performanceunterschieden.


    Beispiel: Mountet man per UDP und es treten Netzwerkprobleme auf, dann kann ein Schreibvorgang die gerade zu schreibende Datei korrumpieren. Das passiert sogar ziemlich oft (verworfene Pakete), fällt aber bei Audio- und Videostreams nicht sofort auf, wenn einige Bytes kaputt sind. Das kann bei TCP nicht passieren, da es dort eine Fehlerkontrolle gibt.


    Dito die Mountparameter die dafür sorgen, das ein gerade abgeschaltetes NAS den Klienten nicht irritiert. Und das, wenn es wieder angeschaltet ist, die Freigaben auf dem Klienten auch wieder sichtbar sind ...


    Die Entscheidung, welche von diesen Argumentationen du jetzt für dich (und nur darum geht es, nicht ums Rechthaben) als sinnvoll erachtest, bleibt dir überlassen. :D

  • es wird mit dem systemd auch deutlich frueher im boorvorgang gemountet, was aber nur im DreamOS wichtig ist da es auch deutlich schneller bootet. Ausserdem werden aus jedem mount systemd services die man selektiv enabeln disabeln kann statt jedesmal die config anpassen und rebooten zu muessen

  • Leider habe ich nun doch einen Nachteil festgestellt. Eine Box hängt mit einem Power dLAN von Devolo mit 105Mbit/s im Netzwerk und wenn ich auf dieser Box einen HD Film von einer anderen Box anschaue, dann stockt der Film alle 10-15s. Wenn ich den mount aus dem Automounter nutze dann läuft alles flüssig ohne die Ruckler.


    Kann ich hier an dem ein oder anderen Buffer drehen um das Ruckeln zu beseitigen oder muß ich die Box wieder zurückbauen auf Automounter?

  • Du kannst gerne an de Buffern drehen. Beispiel:


    Code
    1. tcp,x-systemd.automount,rsize=8192,noauto,wsize=8192,retry=0,x-systemd.idle-timeout=60,nolock,rw,timeo=2,retrans=1,x-systemd.device-timeout=2,soft,vers=3


    ... also an rsize und wsize

  • Hallo nochmals,


    also ich habe ebenfalls eine Sache gefunden die so unter den Automounts nicht passiert. Das verändern der Buffer hat mir dabei nicht geholfen. Ich habe den Timeshift auf mein NAS gelegt.

    Das hat immer sehr gut funktioniert. Nun ist im NAS eingestellt dass die FEstpllatten nach 1 Stunde Inaktivität in den Sleep gehen. Unter den Automounts hat selbst das geklappt. Sprich hier hat sich die Box eine kurze Auszeit genommen den Spinner angezeigt und nach ca. 20-30 sek war der Timeshift aktiv. Unter der FSTAB klappt das nicht. Wenn die Festplatten im Standby sind und ich den Timeshift aktiviere zeigt dieser nach ca. 10 sek nur an Timeshift nicht möglich. Allerdings klappt es dann sofort beim nächsten Pause drücken.


    VG S

  • Das kann aber auch ein Timeout Fehler des NAS sein (Beispiel: Synology Zeugs mit mehr als einer Festplatte braucht fast 30 Sekunden, bis die aus dem Standby wieder hochgefahren sind. Das liefert sogar bei SMB Shares erst einmal ein "not ready" zurück).


    Setze mal "retry" auf 1 oder 2. Oder guck dir einfach mal die ursprünglichen Automount Einträge in der fstab an.

  • Hallo nochmals,


    sorry wenn ich damit nerve aber irgendwie scheint das Ganze nicht so zu funktionieren wie es soll.

    Bei mir läuft sowohl das Aufnahmeverzeichnis als auch das Timeshiftverzeichnis auf meine NAS. Die Platten fahren irgendwann in den Standby und es dauert ca. 30sek bis diese wieder Verfügbar sind. Soweit so gut. Nun habe ich in den letzten 2 Tagen insgesamt 3 Abstürze (GreenScreen gehabt) Ausgehend vom Timeshiftplugin (siehe LOG anbei).


    Ich habe daraufhin nochmals alles neu aufgesetzt und gerade eben schon wieder :-( Da ich das Timeshift Verzeichnis seit Jahren ausgelagert habe und nie Probleme hatte, meine ich dass das eigentlich gehen sollte. Jedenfalls ist eine interne Platte nur für Timeshift keine Option.


    Zudem dachte ich dass das so stabil läuft aber das tut es leider überhaupt nicht. Hat jemand noch eine Idee an welchen schrauben man drehen kann? Die Abstürze treten immer nachdem Aufwecken auf.


    Nachdem das mit rsize=8192 bzw.wsize=8192 noch mehr Probleme gemacht hat sieht meine aktuelle FSTAB so aus:


    Code
    1. 192.168.27.10://mnt/LPS/aufnahmen /media/nas nfs tcp,x-systemd.automount,x-systemd.idle-timeout=60,x-systemd.device-timeout=2,nolock,rw,timeo=2,retry=1,retrans=1,soft,noauto,vers=3 0 0

    VG S

  • Wozu die Platten in Standby schicken? Moderne NAS Platten sind auf 24/7 Dauerbetrieb ausgelegt und Standby ist da eher kontraproduktiv.

    Die 1-2W Unterschied machen sich nicht mal merklich auf der Stromrechnung bemerkbar.


    Und sorry, timeshift gehört auf ein lokales device und wenn es nur eine alte ausrangierte SSD oder HDD ist. Bei den derzeitgen SSD Preisen würde ich nicht viel nachdenken. Da sind die paar Stunden Ärger ohne lokales timeshift devecie schnell amortisiert ...


    Auch Freizeit kann man in Geld umrechnen ;)