Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Absturz (GreenScreen) beim Laden von Picons

  • Wenn du mich meinst. Nö.


    Kenne halt vom Newnigma, daß der Name exakt dem gesendeten Namen entsprechen muß.

    Z.B. gotv NEU.png.

    Dachte es wär im Merlin gleich.


    Klappt das eigentlich nur mit dem skincomponent reftopiconname oder auch mit dem DP eigenen picon.py?


    Habs nur mit DP eigenen getestet.

  • RefToPiconName ist ein Converter, Picon ein Renderer. Und ja, spaces werden durch _ ersetzt.

  • Reference:

    ====> picon name is: /data/picon_220x132/1_0_19_6EA5_4B1_1_C00000_0_0_0.png


    Name:

    ====> picon name is: NDR_FS_MV_HD


    Putgemacht. Kein Pfad, kein Extensionname :undweg:


    Wer bei Drei nicht auf dem Baum ist, darf das fixen :D

  • RefToPiconName braucht es gar nicht, das macht alles der PiconResolver. Nicht ganz das Standard-Pattern hier. Ist jedenfalls gefixt. dreamer-flt darf testen. Er hat das ja mal gewünscht ;-)

  • Ach was ist das lecker. Mal wieder was zum testen, danke.


    Hintergrund, warum ich vom Reference-Benamungsgedöhns zu Name zurück will:


    Ich habe DVB-C, DVB-T2 und DVB-S (20 SAT-Positionen) Empfang auf der Dreambox. Bei den diversen SAT-Positionen ändert sich alle Naselang die Reference, da habe ich keine Lust immer der Reference hinterherzujagen. Und die Redundanzen, die Picons dann auch noch mal für DVB-C und DVB-T im System bereitzustellen, sind auch Blödsinn.


    Und ja, ich weiß warum Reference-Benamung damals einführt wurde. Für die paar exotischen Fälle habe ich aber keine Lust mehr, mir diesen Klotz ans Bein zu binden. Lebenszeit ist kostbar :D

  • keine Ahnung ob ich hier richtig bin, aber ich habe ein sehr ähnliches Problem: "GreenScreen beim Laden von Picons"

    Allerdings passiert mir das nach dem manuellen editieren meiner IPTV "Sender".

    Ich habe mir die öffenlichen als IPTV Bouquet angelegt und das läuft auch klasse.

    Beim "ZDF HD" habe ich einen Stream gefunden der inkl. Picon und EPG ist:

    #SERVICE 4097:0:19:2B66:3F3:1:C00000:0:0:0:http%3a//zdf1314-lh.akamaihd.net/i/de14_v1@392878/master.m3u8:ZDF HD IPTV


    Also habe ich das Gleiche für das "Das Erste" gemacht, der ogiginal so ausschaut und auch läuft:

    #SERVICE 4097:0:1:0:0:0:0:0:0:0:https%3a//daserstelive-lh.akamaihd.net/i/daserste_de@38086/index_2692_av-p.m3u8?sd=10&rebase=on&id=:Das Erste IPTV


    nach meiner manuellen Änderung schaut er dann so aus (gemäß den Settings vom ZDF):

    #SERVICE 4097:0:1:6DCA:44D:1:C00000:0:0:0:https%3a//daserstelive-lh.akamaihd.net/i/daserste_de@38086/index_2692_av-p.m3u8?sd=10&rebase=on&id=:Das Erste IPTV

    Tja, wenn ich aber dann auf den Sender schalte, dann gibt es einen Green Sreen.

    Was mache ich denn falsch?

  • Was soll ich sagen, ich habe eben nochmals das Bouquet bearbeitet um den Fehler wieder herzustellen und um den dump zu posten und siehe da, es hat einfach funktioniert!?!?

    Ich habe jetzt auch noch den "hr fernsehen" geprüft und da hat es auch sofort geklappt.

    Sorry, offenbar hatte ich wohl "Schmutzzeichen" in meiner Zwischenablage vom Notepad++


    Ich werde jetzt mal die restlichen Sender alle durchgehen und mich dann nochmal melden.... wird aber wohl etwas dauern ...;)


    EDIT: So, ich habe nun alle 28 Sender bearbeitet und bei allen hat es funktioniert. Sorry, da hatte ich am Wochenende wohl irgendwie Murks gemacht :think: :wand:

    Grüße Attila

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von AttilaE () aus folgendem Grund: Neue Infos