Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Mediaportal

  • ich muss mich nochmal zum thema melden. vor kurzem gabs ein update des plugins mp.

    auf der 7080 mit merlin4 ging alles glatt. auf der 920 ist das mp nach update nicht mehr sichtbat und ich bekomme die meldung das "python-js2py" fehlt. jetzt hab ich gestern schon gegoogelt, aber nix gefunden, wie ich das wieder "flott" machen kann, bzw wo ich diese python komponente finden und downloaden kann. kann mir jemand da weiterhelfen?

  • auf der 900er mit Merlin - keine Prpbleme

    bei NN fehlte auch python-js2py

    bei .ipkg wurde der download nicht gefunden - manuell install


    sky4

    was kommt bei deiner 920,wenn du

    apt-get clean && apt-get update && apt-get install python-js2py

  • ich danke euch erstmal für eure hilfe. komme leider erst morgen dazu zu testen, werde dann aber sofort berichten.

  • so, konnte doch jetzt schon mal testen.

    also ich habe die box mal komplett neu geflasht und mp als erstes mp installiert.

    dhwz python-js2py ist definitv für dm920 nicht vorhanden. ich hatte dasselbe ergebnis. mp war nicht sichtbar. erst als ich die datei von JörgH61 (vielen dank nochmal dafür :topok:) nachinstalliert und einen gui neustart gemacht habe, war mp wieder sichtbar.


    wie gesagt, auf der 7080 hatte ich keinerlei probs mit dem update.

  • auf dem 920 feed ist python-js2py jetzt drauf

    Gruß Jörg


    DM900 Merlin OE2.5 + GP4.0
    DM7080 Merlin OE2.5 + GP4.0
    Sony KD-65XD8577
    Samsung UE55D8090
    Synology DS918+/DS214

  • Bei einem Update über das Plugin ist es sehr wohl vorhanden.

    mp lies sich ja nicht updaten, es kam die meldung das python-js2py fehlt. und da es jetzt erst für dm 920 auf dem feed liegt, ist es ja nur logisch das es nicht geklappt hat.

  • Bei einem Update über das Plugin ist es sehr wohl vorhanden und für eine Neuinstallation muss das Script verwendet werden.

    dhwz :

    Ohne Experte zu sein und vielleicht hab ich's auch einfach nicht kapiert, wie's richtig gehen soll, aber so wie ich's sehe, gibt's 2 Probleme (zumindest bei mir auf DM920):


    1. Dein Script funktioniert unter Merlin nicht wie's soll, ich hab's so hingekriegt:

    wget (mittlerweile am Feed) und apt-transport-https manuell vorab installiert;

    Dein Script angepasst, sodass etwas nicht mitinstalliert wird, über das hier nicht gesprochen werden darf (ansonsten schlägt die Installation nämlich auch fehl) und damit MP installiert;

    ****.list (weiss nicht mehr wie ich zu der gekommen bin) nach Sources.list.d kopiert und über Addon-Manager installiert


    Mag für dich krude wirken aber bei mir hat's so funktioniert und kompletter PC-Dödel bin ich auch nicht...


    2. Und wenn's dann installiert ist und das Update angezeigt wird, funktioniert dieses wegen fehlendem python-js2py nicht:

    Manuell installiert und dann geht's;


    Gibt natürlich noch andere Möglichkeiten der Installation, die hab ich aber nicht mehr durchgespielt

    nachdem's bei mir funktioniert hatte...


    LG Michi

  • mp lies sich ja nicht updaten, es kam die meldung das python-js2py fehlt. und da es jetzt erst für dm 920 auf dem feed liegt, ist es ja nur logisch das es nicht geklappt hat.

    Nochmal es liegt auf dem MP-Feed, das Paket konnte auch zuvor schon installiert werden.


    elliott71

    Scheinbar hast du ein völlig falsches Script wenn du etwas entfernst was damit gar nicht installiert wird. ;)
    python-js2py liegt auf dem MP-Feed und wird daher auch automatisch mitinstalliert, das gilt übrigens auch für wget (auch wenn es gar nicht mehr verwendet wird).



    https://feed.mediaportal.info/

  • Scheinbar hast du ein völlig falsches Script wenn du etwas entfernst was damit gar nicht installiert wird. ;)

    python-js2py liegt auf dem MP-Feed und wird daher auch automatisch mitinstalliert, das gilt übrigens auch für wget (auch wenn es gar nicht mehr verwendet wird).



    https://feed.mediaportal.info/

    Ich kann nur berichten wie's letzte Woche bei mir war auf einem frischgeflashtem Merlin, und eigentlich bin ich mir sicher, keinen Fehler gemacht zu haben...

    Script war FullInstallation ;), die anderen hab ich - wie geschrieben - nicht mehr probiert

  • Und wenn's dann installiert ist und das Update angezeigt wird, funktioniert dieses wegen fehlendem python-js2py nicht

    so siehts aus. bei mir kam erst "update fehlgeschlagen. bitte überprüfen sie das updatelog" oder so ungefähr, und bei näherer betrachtung fehlte dann eben python-js2py. und da beisst die maus kein faden ab. erst nach der manuellen installation war mp dann im menü zu sehen. bei der 7080 ging das reibungslos.


    ich bin nur drauf aufmerksam geworden, weill ein bekannter von mir (mp-junkie)mich anschrieb, dass es sich auf der 920 nicht updaten lässt. und wie man sieht, waren es mit mir, ihm und elliott71 , schon 3 besitzer einer dm 920 mit gleichem image. also 3x dämlich anstellen - eher unwahrscheinlich.

    deshalb hab ich´s mir (noch)mal auf die box gemacht. selbst verwende ich mp wegen sowas und anderer dinge schon seit jahren nicht mehr.


    egal, geht jka jetzt wieder. er ist zufrieden und ich habs wieder von der box, hehe.

  • Dann spar dir bitte deine ewigen schlauen Kommentare wenn du es denn gar nicht verwendest.

    Das Update ging nur die ersten 15min nach Veröffentlichung nicht bis der erste gemeldet hatte dass auf seinem Feed das Paket fehlt.


    Wenn ich schreibe es funktioniert dann tut es das auch.


    Und Mal davon abgesehen werden eh keine Images unterstützt die nicht dem DP Unstable stand entsprechen (dazu zählt auch wenn einfach Pakete von Feed verschwinden die im OE unter devtools drin sind).

  • Dr.Best

    Weißt du doch selbst jedes mal wenn ihr verzögert updated und/oder nicht alle Pakete auf dem Feed liegen habt obwohl sie im meta-opendreambox enthalten sind (so gerade erst geschehen mit python-js2py, liegt bei DP seit 3 Jahren auf dem Feed, ist bei euch und auch bei NN2 aber vom Feed (teils) verschwunden). ;)

    Oder eurer apt-get sich nicht wie bei DP verhält (warum eigentlich?). Wenn du nicht weißt was ich meine, "apt-get install -y apt-transport-https" läuft bei euch auf einen Fehler warum weiß der Geier. Angeblich braucht ihr ein --force-yes (das ist eigentlich deprecated und werde ich ganz sicher nicht verwenden, geht bei DP ja auch ohne).

  • Ich weiß nicht, warum die python-js2py vom 920 Feed verschwunden ist, ich sehe nur, dass sie für die anderen Boxen seit 3 Jahren auf den Feeds liegen.

    Ich kann auch mit


    Zitat

    install apt-transport-https


    bei mir auf der 7080 ohne Probleme die Pakete installieren.


    Ich weiß auch, dass wir nichts an apt-get geändert haben.

    Warum also bei uns der Befehl


    Zitat


    apt-get install -y apt-transport-https



    zu


    Zitat

    WARNING: The following packages cannot be authenticated!

    libcurl4 apt-transport-https

    E: There are problems and -y was used without --force-yes



    führt und bei DMM nicht (ich habs nicht getestet) weiß ich nicht. Das müsste ich mal richtig recherchieren.


    Was ich weiß ist, dass alles lösbar ist, wenn man nachfragt, denn wie gesagt, ich konnte das Paket ohne Probleme installieren.


    Mir ist die ganze Install-Prozedur vom MediaPortal eh nicht klar... :) Hier ein neuer Feed, hier Pakete, die mal auf dem MP Feed liegen, mal müssen sie bei uns liegen....als Außenstehender blicke ich da nicht durch. ;)

  • So, mittlerweile weiß ich auch, warum ein "-y" bei uns so nicht funktioniert wie bei DMM: die signieren ihre Feeds, das machen wir so nicht. Deswegen kommt bei uns die "not authenticated" Meldung.


    Ich hab nun mal was bei mir was geändert, nun geht das auch so wie bei DMM...