Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Merlin + Kodi

  • Hi,I have the same problem as nick @Purgy

    Purgy he writes:


    Ich habe hier ein kleines Problem auf der DM900, wenn ich das neue GP4 mit installierten Kodi laufen lassen will.


    Mal ein kleines Beispiel dazu:



    Als Basis habe ich ein Backup-Image mit Merlin vom Mai 2018. Darauf installiere ich dann das GP4 und installiere dann vom Addon Manager aus das Kodi Mediacenter. So weit so gut, aber es laufen damit einige (legale) Sport Addons nicht, wie z.b. Telekom Sport. Der Stream startet dann, aber bleibt dann hängen.


    Nun flashe ich das gleiche Backup-Image neu und nehme dann das GP3.3 und installiere dann ebenfalls das Kodi per Addon Manager. Dann funktioniert wieder alles wie gewohnt und die Streams laufen. Da scheint also irgendwo was falsch installiert zu werden, beim GP4. Aber was ?


    Dann gibt es seit neuesten ja nach dem Beenden von Kodi noch einen kosmetischen Fehler, denn dann hängt das System und läßt sich per Remote nicht mehr bedienen, außer mit der Power-Taste in den Standby. Das scheint aber am enigma zu liegen ?


    Wäre schön wenn hier einer Licht ins Dunkel bringen kann.





  • Wenn Kodi ohne GP4 betrieben wird, kannst du gerne hoer fragen. Sonst soll sich die GP4-Truppe drum kümmern.

  • Ok, die Frage stammte ja ursprünglich von mir, aber abgesehen vom GP3.3/GP4 habe ich Kodi natürlich auch nur mit Merlin ausprobiert.

    Also lassen wir das GP3.3/4 jetzt mal weg und konzentrieren uns aufs Merlin ;)

    Für Kodi muss ich dann ja einiges händisch installieren. Folgende Pakete habe ich genommen:


    kodi
    libkodiplatform17.0
    enigma2-plugin-extensions-kodimediacenter
    libmicrohttpd10
    libmysqlclient18
    libnfs1
    libssh
    libtinyxml2.6.2
    libyajl2
    gstreamer1.0-libav


    Nach Neustart erscheint dann auch brav Kodi im Menue und es startet auch, aber es fehlt komplett der Zeichensatz, also weder Englisch noch Deutsch, rein gar nichts zu lesen. Nur die Symbole erscheinen.

    Ich habe dann manuell die Sprachdatei "resource.language.de_de.zip" nach /root/.kodi/addons entpackt und Attribute angepasst. Hat aber leider nichts gebracht.

    Hat vielleicht noch jemand einen Tipp ?

    Übrigens der kosmetische Fehler den ich oben beschrieben habe, ist auf jeden Fall schon mal verschwunden ohne GP3.3/4.


  • Da wir selber KOdi nicht nutzen müßtest du dich gedulden bis sich eventuel pclin hier meldet.Auf jeden Fall schaut der hier noch vorbei.


    Frage wäre noch zu klären ob es beim Orginal-Image auch die selben Probleme gibt.

  • Purgy Wenn du nur Symbole, keine Schrift hast, fehlen die Recommends

    Code
    1. apt update
    2. apt install glibc-charmap-ibm850, glibc-gconv-utf-32, glibc-localedata-en-us, python-shell, python, python-json, python-html, python-ctypes, python-difflib, glibc-gconv-ibm850, glibc-gconv-unicode, libcurl4, libcec4, python-compression, python-zlib, python-sqlite3, python-re, python-lang, python-netclient, glibc-charmap-utf-8

    gruß pclin

    Die zwei Gemütszustände eines Programmierers

    0 ich hab keine Ahnung was ich hier mache

    1 ICH BIN GOTT

    ---

    DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n

    (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+x11, merlin4, debian-stretch, Diverse

    ---

    AudioDSP: miniDSP 2x4 HD

    TV: LG 65" SUHD

  • crashllog kodi



    11:49:34.832 T:3008213568 NOTICE: closing down remote control service


    11:49:34.832 T:3008213568 NOTICE: stopped


    11:49:35.033 T:3008213568 NOTICE: destroy


    11:49:35.033 T:3008213568 NOTICE: unload skin


    11:49:35.068 T:3008213568 NOTICE: unload sections


    11:49:35.078 T:3008213568 NOTICE: special://profile/ is mapped to: special://masterprofile/


    11:49:35.079 T:3008213568 NOTICE: PVRManager - stopping


    11:49:35.146 T:2619925376 ERROR: GetMasterProfile: master profile doesn't exist


    11:49:35.157 T:3008213568 ERROR: Previous line repeats 29 times.


    11:49:35.158 T:3008213568 NOTICE: application stopped...

  • Quizfrage ,

    Was hat

    GP4 + Kodi

    mit Merlin zu tun

    Solche Fragen sind doch besser im GP Board aufgehoben

    Ne geht nur noch ums Merlin, nix GP, lese mal alles durch dann weißt du bescheid ;)

    Der Threadtitel müsste nur geändert werden.

  • Pepik71 : please attach complete crashlog as file. But remember:

    Gp4 installed, no support. Only without gp4

  • Wenn du nur Symbole, keine Schrift hast, fehlen die Recommends

    Danke jetzt scheint alles zu flutschen.


    Hier nochmal die ganzen Pakete, womit ich es bei mir zum Laufen gebracht habe:


    kodi

    libkodiplatform17.0
    enigma2-plugin-extensions-kodimediacenter
    kodi-addon-pvr-vuplus
    libmicrohttpd10
    libmysqlclient18
    libnfs1
    libssh
    libtinyxml2.6.2
    libyajl2
    gstreamer1.0-libav


    libcec4_4.0.2_git0_5250931f16-r0.0

    libxrender1_0.9.9-r0.0

    libx11-6_1.6.3-r0.0

    libxau6_1.0.8-r0.0

    libxcb1_1.11.1-r0.0

    libxdmcp6_1.1.2-r0.0

    libxrandr2_1.5.0-r0.0

    libxext6_1.3.3-r0.0


    Code
    1. apt install gstreamer1.0-plugins-base-apps gdb glibc-charmap-ibm850 glibc-gconv-utf-32 glibc-localedata-en-us python-shell python python-json python-html python-ctypes python-difflib glibc-gconv-ibm850 glibc-gconv-unicode libcurl4 libcec4 python-compression python-zlib python-sqlite3 python-re python-lang python-netclient glibc-charmap-utf-8
    Code
    1. apt install libswscale4 libpostproc54 libavfilter6
    Code
    1. apt install kernel-module-cdc-acm

    Also die Addons die ich eben testen konnte, liefen damit ohne Probleme und Kodi bleibt nach dem Beenden auch nicht hängen. Danke für die Hilfe hier ;)

    Kann jemand noch den Thread Titel vielleicht ändern in "Merlin + Kodi" oder so. THX


    Edit: die urlib.py und urlib2.py hatte ich auch noch ausgetauscht in /usr/lib/python2.7

  • Code
    1. root@dm900:~# apt install libkodiplatform17.0
    2. Reading package lists... Done
    3. Building dependency tree
    4. Reading state information... Done
    5. E: Unable to locate package libkodiplatform17.0
    6. E: Couldn't find any package by regex 'libkodiplatform17.0'
    7. root@dm900:~#


    kein plan, die die urlib.py und urlib2.py bräuchte ich dann auch?

  • ne .. die abhänigkeiten gehen dann .. das libkodibumsdabums mußt du dir schon selber besorgen ..

    pclin hat die wohl im dreamforum hochgeladen.