Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Beiträge von s25a

    Hallo,


    vielen herzlichen Dank - ich konnte den Übeltäter finden.

    War wie vermutet eine abgebrochene Aufnahme die cih aber ohne die Anleitung nicht identifizieren konnte.


    Eine Sache die mir im WIKI aufgefallen ist und die etwas verwirrt: (nur eine Kleinigkeit aber ich bin natürlich drübergestolpert :-) )

    Liest man das von oben nach unten steht irgendwann dass man einen mount im tmp machen soll



    (Unter Vorgehensweise / Anwendbar in folgenden OE1.6 - OE2.5)

    Flash als bind mount nochmal mounten >


    Code
    1. mkdir /tmp/flash
    2. mount -o / /tmp/flash




    Das funktioniert nicht - da fehlt das "bind". Der richtige Befehl steht dann erst weiter unten



    Code
    1. root@dm900uhd:~# mkdir /tmp/flash
    2. root@dm900uhd:~# mount -o bind / /tmp/flash

    Hallo Zusammen,


    meine Box läuft jetzt schon einige Tage, wollte gerade ein Plugin installieren und Prompt wurde es abgebrochen da der Speicher voll ist.


    Code
    1. root@dm920:~# df -T -h
    2. Filesystem Type Size Used Available Use% Mounted on
    3. /dev/root ext4 960.4M 916.3M 0 100% /


    Nun bin ich etwas erstaunt da ich lediglich ein paar Plugins und 1 Skin installiert habe. Wie find eich den am Besten heraus was mein System hier zumüllt und vor allem wie bereinige ich es dann.

    Ich habe ein paarmal Updates gemacht eventuell liegt es daran.


    Bin auf Linux nicht wirklich fit. Über ein paar Befehle konnte ich zumindest mal die Verzeichnis Größen herausfinden. (Bitte das /media Verzeichnis ignorieren dadrunter ist ein Pfad von meinem NAS gemountet)

    Wenn ich das alles zusammenzähle komme ich auf ca. 600MB wo sind die restlichen 400MB?


    Hallo,


    danke für die Antwort. Aber so wollte ich das nicht. (Auch wenn die Idee gut ist. Das lässt sich aber mit meiner alternativen Fernbedienung nicht umsetzen.)


    Irgendwo in der Key map müsste doch stehen was passiert wenn die Info bar offen ist und genau dadrunter sollte dann definiert werden dass Exit diese zumacht.


    Danke und VG S

    Hallo nochmals,


    kennt sich jemand mit der keymap.xml aus? Ich würde gerne die Taste "Exit" auf der Fernbedienung der 0 zuweisen - nur wenn TV läuft (kein Menu offen)

    Es gibt dort ja etliche Abschnitte ich bin mir nicht sicher wo ich das platzieren muss.


    Danke und VG S


    P.S Durch ein bisschen Ausprobieren habe ich es soweit hinbekommen


    <map context="NumberActions">

    <key id="KEY_1" mapto="1" flags="m" />

    <key id="KEY_2" mapto="2" flags="m" />

    <key id="KEY_3" mapto="3" flags="m" />

    <key id="KEY_4" mapto="4" flags="m" />

    <key id="KEY_5" mapto="5" flags="m" />

    <key id="KEY_6" mapto="6" flags="m" />

    <key id="KEY_7" mapto="7" flags="m" />

    <key id="KEY_8" mapto="8" flags="m" />

    <key id="KEY_9" mapto="9" flags="m" />

    <key id="KEY_0" mapto="0" flags="m" />

    <key id="KEY_EXIT" mapto="0" flags="m" /> / NEU

    </map>


    Was allerdings damit passiert ist, dass der Letzte Kanal auch dann ausgelöst wird wenn die Info-Leiste offen ist. Das sollte natürlich nicht sein. Die Sollte einfach verschwinden beim Exit-Taste drücken

    Weiß jemand worunter dies fällt? Ansonsten klappt es wunderbar in sämtlichen Menus

    Hallo Zusammen,


    ich versuche gerade eine Funktion einzubauen bei der man im Normalen TV Betrieb über die Taste Exit den letzten Kanal aufrufen kann.

    Damit ich die Möglichkeit habe zwischen 2 Kanälen hin und herzuschalten.


    Gibt es sowas? Über das Multi Quickbutton Plugin gibt es ZAP History -/+ was schon mal ganz gut ist aber einen Toggle habe ich nicht gefunden.

    Eventuell über die KEymap.xml aber bevor ich dort einsteige wollte ich mal lieber vorher nachfragen :-)


    VG S

    Hallo Zusammen,


    Vielen Dank für den Tipp mit den Sonderzeichen so klappt es jetzt. Vielen Dank auch für den Tipp mit dem Picon Loader und dem Speichern unter dem Namen. Das wusste ich nicht dass man die Dateien als Name bekommen wenn unter den Skin Einstellungen "Name" angegeben ist. Sehr praktisch um einmal Piccns zu laden


    VG S

    Hallo,


    nein das wäre ja die Reference Methode. Ich habe es auch gerade nochmal ausprobiert. Geht nicht

    Ich wollte ja die Methode "Name" da ich einen Kabelanbieter habe der nicht in der Liste ist und nicht alles manuelle mappen möchte.


    Viele Grüße


    S

    Hallo Nochmals,


    mittlerweile habe ich die meisten Piccons mit "NAME" eingerichtet und das funktioniert auch soweit. Es gibt ein paar Sender welche Sonderzeichen enthalten da schaffe ich es nicht diese einzubinden.

    Gibt es irgendwo eine Anleitung dazu?


    Beispiel:

    SAT.1 HD: Meine Datei heißt SAT.1_HD.png. Das zeigt er aber nicht an

    BR Fernsehen Süd: Meine Datei heißt BR_Fernsehen_Süd_HD.png. Das zeigt er aber auch nicht an.


    Ich gehe von aus dass die Sonderzeichen das Problem sind.


    Viele Grüße S

    Hallo nochmals,


    schon etwas älter der Beitrag aber eventuell hab ich einen Bug gefunden - wäre prima es könnte jemand mal auf seinem System ausprobieren.


    Es geht um:


    "KEY_REWIND": 168,

    sowie

    "KEY_FASTFORWARD": 208,


    aus der /usr/lib/enigma2/python/keyids.py


    Diese lösen normalerweise zurück und Vorspulen aus. Auf meiner DM920 mit aktuellem Merlin OE2.5 passiert aber nichts.


    Getestet über:

    http://IP/web/remotecontrol?command=168


    Auf der Box erscheint nur ein kleines rotes X (Das der Befehl nicht funktioniert)


    Die Tasten auf der Fernbedienung gehen problemlos auch alle anderen Befehle aus der Keypids....Nur diese beiden eben nicht.


    VG S

    3-4 HD Aufnahmen/Streams gleichzeitig hat sogar meine DM800se v1 über das Netzwerk geschafft, das sollte für die dm9x0 kein Problem kein, wenn das NAS mitspielt.

    Das denke ich eben auch dass das für eine Dreambox 920 kein Problemm sein sollte deswegen hat mich die Aussagen von dreamer etwas erschreckt. Vielleicht kannst du dass nochmals etwas genauerausführen. Sollte die Dream damit wirklich ein Problem haben dann wäre die Frage wieso.


    Und klar dass NAS und Netzwerk muss das natürlich schaffen. Ich schreibe momentan auf ein Feeenas mit 4 Platten. Da ist ein Xeon V3 mit 16GB Ram verbaut. Das sollte mehr als ausreichend Leistung haben um das zu verarbeiten.

    Ich kann testwesie auch auf eine QNAP umschwenken wobei ich nicht glaube das die Performance hier besser ist.


    Bzgl. des Skriptes bin ich etwas weiter. Über einen Tip aus dem Dreambox Forum bin ich hier gelanded:

    ExecuteOnPowerEvent Plugin


    Damit werde ich mal testen und kucken ob das zuverlässig funktioniert. Damit wäre ich schonmal ein gutes Stück weiter :-)


    VG S

    Hallo nochmals,


    dreamer : Danke für die ausführlichen (und vor allem ehrlichen Infos) Infos.



    Zitat

    Es hat schon seinen Grund, warum die Fehlchargen der 900/920 bevorzugt bei hoher Netzwerkauslastung freezen. Oder eben bei UHD Content


    Die Aussage erschreckt mich jetzt etwas...

    Ist das denn nur bei der Dream so oder generell bei Enigma basierten Geräten? Ich habe mir diese zugelegt da ich viel aufnehme und alles über das Netzwerk speichere (Kabel sind überall verlegt kein W/Dlan alles Gigabit Netzwerk über CAT7 Verlegekabel).

    Die DM920 ist doch das Top Modell und mit Unicable hat diese bei mir 8 interne Tuner. Das System sollte mindestens 3-4 Aufnahmen parallel schaffen plus kucken und Timeshift.


    Oder sind meine Ansprüche da zu hoch?


    Zitat

    Schau dir mal die Auslastung des Systems bei Netzwerktraffic an

    Und wie messe ich das am Besten?


    Viele Grüße


    S

    Hallo Nochmals,


    also ich weiß nicht ob das Quatsch ist - viele User berichten dass es bei Ihnen problematisch mit der Wärme ist. Gibt auch einige Projekte mit Lüfterumbau etc. Eine SSD braucht zwar deutlich weniger Strom als eine HDD aber wenn ich mir mal meine Samsung SSDs und deren Temperatur ohne Kühlung anschaue dann weiß ich nicht was bei dir Umgebungstemperatur ist :-)


    USB Stick halte ich auch für keine zielführende Idee.


    dreamer : Der Timeshift läuft nur im Betrieb ansonsten wenn die Box im Standby ist natürlich nicht. Permanent alles aufzuzeichnen ist natürlicher vollkommener Blödsinn :-)


    Könnte man denn ohne Modifikation des Timeshift Plugins folgendes machen: Sobald die Dreambox startet über ein Script eine einfache Dateioperation auf dem NFS Share auslösen (Z.B. ein ls /nfsshare). Das reicht um die Platten hochfahren zu lassen zumindest hat es das bei mir gerade gemacht.

    Ich weiß dass es über einen Crontask @reboot als Auslöser gibt. Jemand eine Idee ob so was ähnliches auch für ein Dreambox Aufwecken möglich ist?


    Vielen Dank und Grüße S

    Zitat

    ich will ja nur, ich glaube, vielleicht ... Bei OE2.5 wird ALLES über fstab eingebunden. Parametrisieren darfst du dann selber. Und warum das nicht *zuverlässig* klappt ist auch erörtert und war eben keine separate Diskussion. Permanent Timeshift auf ein gemountetes Netzwerkgerät ist halt eine GANZ miese Idee. Ich habe fertig und bin raus.

    Hallo nochmals,


    dann bringe ich noch einen anderen Aspekt mit rein. Meine Dream 920 steht versteckt in einem Regal. Diese wird im Vergleich zu anderen Boxen die ich so über die letzten Jahre hatte deutlich wärmer. Wenn ich nun auch noch eine Zusätzliche Platte einbaue wird das sicherlich nicht besser. Und da das Auslagern des Timeshiftes nie Probleme gemacht hat würde ich es gerne so weiter-nutzen. Ich glaube auch nicht dass die Methode des Einbindes hier das Problem ist sondern eher wie das Timeshift Plugin damit umgeht.


    Man könnte das Plugin so einstellen dass es erst 1 Minute nach dem Umschalten auf einen Sender mit dem Permanent Timeshift beginnt. Zusätzlich gibt es schon mal vorab aus dem Plugin eine Abfrage an das Verzeichnis. Ich formuliere es jetzt mal laienhaft - so eine Art ausprobieren ob das Verzeichnis existiert ohne das wirklich geschrieben wird. Das würde die Festplatten schon antriggern und sobald dann der eigentlich Schreibvorgang losgeht klappt alles.


    Für mich ist das übrigens keine Zeitverschwendung - ich experimentiere halt gerne und wenn dann irgendwann alles klappt ist dass doch auch schon ein ganz netter Erfolg :-)


    Viele Grüße


    S

    Hallo nochmals,


    abgesehen davon ob es nun Sinn macht seine Festplatten in den Standby zu fahren oder nicht. Ich denke das ist eine separate Diskussion. Mir ging es ja letztlich nur darum ein möglichst zuverlässiges System zu haben dass


    a) Den Share zuverlässig und performant einbindet und

    b) Den Client nicht zu Abstürzen bewegt.


    Mir kommt es halt vor als würde beim Einbinden über die FSTAB etwas schiefgeht denn ich habe Abstürze der Box und Meldungen dass der Timeshift nicht zur Verfügung steht.

    Vielleicht ist es auch nur das PermamnetTimeshift Plugin dass das alles verursacht aber leider kenne ich keine Alternative. Ich möchte eben dass sobald auf den Kanal geschaltet wird (mit paar Sekunden Verzögerung) der Timeshift automatisch beginnt und nicht erst wenn ich diesen manuell auslöse.


    Viele Grüße S

    Hallo nochmals,


    sorry wenn ich damit nerve aber irgendwie scheint das Ganze nicht so zu funktionieren wie es soll.

    Bei mir läuft sowohl das Aufnahmeverzeichnis als auch das Timeshiftverzeichnis auf meine NAS. Die Platten fahren irgendwann in den Standby und es dauert ca. 30sek bis diese wieder Verfügbar sind. Soweit so gut. Nun habe ich in den letzten 2 Tagen insgesamt 3 Abstürze (GreenScreen gehabt) Ausgehend vom Timeshiftplugin (siehe LOG anbei).


    Ich habe daraufhin nochmals alles neu aufgesetzt und gerade eben schon wieder :-( Da ich das Timeshift Verzeichnis seit Jahren ausgelagert habe und nie Probleme hatte, meine ich dass das eigentlich gehen sollte. Jedenfalls ist eine interne Platte nur für Timeshift keine Option.


    Zudem dachte ich dass das so stabil läuft aber das tut es leider überhaupt nicht. Hat jemand noch eine Idee an welchen schrauben man drehen kann? Die Abstürze treten immer nachdem Aufwecken auf.


    Nachdem das mit rsize=8192 bzw.wsize=8192 noch mehr Probleme gemacht hat sieht meine aktuelle FSTAB so aus:


    Code
    1. 192.168.27.10://mnt/LPS/aufnahmen /media/nas nfs tcp,x-systemd.automount,x-systemd.idle-timeout=60,x-systemd.device-timeout=2,nolock,rw,timeo=2,retry=1,retrans=1,soft,noauto,vers=3 0 0

    VG S